Initial import (#2228221)
parent
7222a1e01b
commit
3d9e2b9497
@ -0,0 +1 @@
|
|||||||
|
/gix-config-value-0.12.5.crate
|
@ -1,3 +0,0 @@
|
|||||||
# rust-gix-config-value
|
|
||||||
|
|
||||||
The rust-gix-config-value package
|
|
@ -0,0 +1,22 @@
|
|||||||
|
--- gix-config-value-0.12.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ gix-config-value-0.12.5/Cargo.toml 2023-08-01T18:21:49.452501+00:00
|
||||||
|
@@ -15,7 +15,7 @@
|
||||||
|
name = "gix-config-value"
|
||||||
|
version = "0.12.5"
|
||||||
|
authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
|
||||||
|
-description = "A crate of the gitoxide project providing gix-config value parsing"
|
||||||
|
+description = "Parser for gix-config values"
|
||||||
|
license = "MIT OR Apache-2.0"
|
||||||
|
repository = "https://github.com/Byron/gitoxide"
|
||||||
|
|
||||||
|
@@ -38,10 +38,6 @@
|
||||||
|
features = ["std"]
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
-[dependencies.document-features]
|
||||||
|
-version = "0.2.0"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
[dependencies.gix-path]
|
||||||
|
version = "^0.8.4"
|
||||||
|
|
@ -0,0 +1,85 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate gix-config-value
|
||||||
|
|
||||||
|
Name: rust-gix-config-value
|
||||||
|
Version: 0.12.5
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Parser for gix-config values
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/gix-config-value
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * improve crate summary / description
|
||||||
|
# * drop unused optional dependency that is only useful for building docs
|
||||||
|
Patch: gix-config-value-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Parser for gix-config values.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue