parent
1623e2271d
commit
7bc95b24e5
@ -0,0 +1 @@
|
|||||||
|
/gix-actor-0.24.1.crate
|
@ -0,0 +1,13 @@
|
|||||||
|
--- gix-actor-0.24.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ gix-actor-0.24.1/Cargo.toml 2023-08-01T12:36:15.954841+00:00
|
||||||
|
@@ -46,10 +46,6 @@
|
||||||
|
[dependencies.btoi]
|
||||||
|
version = "0.4.2"
|
||||||
|
|
||||||
|
-[dependencies.document-features]
|
||||||
|
-version = "0.2.0"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
[dependencies.gix-date]
|
||||||
|
version = "^0.7.1"
|
||||||
|
|
@ -0,0 +1,98 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
# Deactivate tests because of a missing dev-dependency (gix-testtools)
|
||||||
|
# See https://github.com/Byron/gitoxide/discussions/900 for more information
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate gix-actor
|
||||||
|
|
||||||
|
Name: rust-gix-actor
|
||||||
|
Version: 0.24.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Way to identify git actors
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/gix-actor
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * Drop documenation feature that is not used in fedora
|
||||||
|
Patch: gix-actor-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A way to identify git actors.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+gix-features-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+gix-features-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "gix-features" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+gix-features-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue