Drop dependency on time ^0.1 which is only required for building examples

epel10
Fabio Valentini 4 months ago
parent f67f14323b
commit e226ffb8ab
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -0,0 +1,12 @@
--- git2-0.18.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ git2-0.18.3/Cargo.toml 2024-09-30T10:34:46.623498+00:00
@@ -51,9 +51,6 @@
[dev-dependencies.tempfile]
version = "3.1.0"
-[dev-dependencies.time]
-version = "0.1.39"
-
[features]
default = [
"ssh",

@ -12,8 +12,14 @@ Summary: Bindings to libgit2 for interoperating with git repositories
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/git2 URL: https://crates.io/crates/git2
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop dependency on time ^0.1 which is only required for building examples
Patch: git2-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 24
%if %{with check}
BuildRequires: /usr/bin/git
%endif
%global _description %{expand: %global _description %{expand:
Bindings to libgit2 for interoperating with git repositories. This Bindings to libgit2 for interoperating with git repositories. This
@ -138,12 +144,11 @@ use the "vendored-libgit2" feature of the "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
# drop examples that pull in time ^0.1
rm -rv examples/
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires
%if %{with check}
echo '/usr/bin/git'
%endif
%build %build
%cargo_build %cargo_build

@ -1,3 +1,8 @@
[package]
cargo-toml-patch-comments = [
"drop dependency on time ^0.1 which is only required for building examples",
]
[features] [features]
hide = [ hide = [
"vendored-openssl", "vendored-openssl",
@ -9,3 +14,9 @@ test = [
"/usr/bin/git", "/usr/bin/git",
] ]
[scripts]
prep.post = [
"# drop examples that pull in time ^0.1",
"rm -rv examples/",
]

Loading…
Cancel
Save