parent
9f53de2e96
commit
16e0ca726b
@ -0,0 +1 @@
|
||||
/git-delta-0.1.1.crate
|
@ -0,0 +1,11 @@
|
||||
--- git-delta-0.1.1/Cargo.toml 2020-04-27T00:06:03+00:00
|
||||
+++ git-delta-0.1.1/Cargo.toml 2020-05-02T08:50:26.849017+00:00
|
||||
@@ -39,7 +39,7 @@
|
||||
version = "0.1.2"
|
||||
|
||||
[dependencies.console]
|
||||
-version = "0.7.7"
|
||||
+version = "0.11.2"
|
||||
|
||||
[dependencies.dirs]
|
||||
version = "2.0"
|
@ -0,0 +1,76 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global __cargo_skip_build 0
|
||||
|
||||
%global crate git-delta
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Syntax-highlighting pager for git
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/git-delta
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Update console to 0.11, https://github.com/dandavison/delta/pull/143
|
||||
Patch0: git-delta-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Syntax-highlighting pager for git.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package -n %{crate}
|
||||
Summary: %{summary}
|
||||
# Install all deps (without check), grab their licenses and make it simple
|
||||
# * ASL 2.0
|
||||
# * ASL 2.0 or Boost
|
||||
# * ASL 2.0 or MIT
|
||||
# * BSD
|
||||
# * ISC
|
||||
# * LGPLv3+
|
||||
# * MIT
|
||||
# * MIT or ASL 2.0
|
||||
# * Unlicense or MIT
|
||||
# * zlib
|
||||
License: MIT and ASL 2.0 and BSD and ISC and LGPLv3+ and zlib
|
||||
|
||||
%description -n %{crate} %{_description}
|
||||
|
||||
%files -n %{crate}
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{_bindir}/delta
|
||||
%dir %{_datadir}/bash-completion
|
||||
%dir %{_datadir}/bash-completion/completions
|
||||
%{_datadir}/bash-completion/completions/delta.bash
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
install -Dpm0644 completion/bash/completion.sh \
|
||||
-T %{buildroot}%{_datadir}/bash-completion/completions/delta.bash
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat May 02 10:50:26 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.1.1-1
|
||||
- Initial package
|
Loading…
Reference in new issue