Update to version 0.26.2; Fixes RHBZ#2107873

epel9
Fabio Valentini 3 years ago
parent d22bb74390
commit 840e4e36f9
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -11,3 +11,4 @@
/gimli-0.24.0.crate /gimli-0.24.0.crate
/gimli-0.25.0.crate /gimli-0.25.0.crate
/gimli-0.26.1.crate /gimli-0.26.1.crate
/gimli-0.26.2.crate

@ -0,0 +1,10 @@
--- gimli-0.26.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gimli-0.26.2/Cargo.toml 2022-08-08T13:45:33.256747+00:00
@@ -16,6 +16,7 @@
exclude = [
"/releases/*",
"/.github",
+ "/fixtures",
]
description = "A library for reading and writing the DWARF debugging format."
documentation = "https://docs.rs/gimli"

@ -1,23 +1,25 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 22
# * resolve circular dependency with object and addr2line # * resolve circular dependency with object and addr2line
%bcond_with check %bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate gimli %global crate gimli
Name: rust-%{crate} Name: rust-gimli
Version: 0.26.1 Version: 0.26.2
Release: %autorelease Release: %autorelease
Summary: Library for reading and writing the DWARF debugging format Summary: Library for reading and writing the DWARF debugging format
# Upstream license specification: Apache-2.0/MIT License: MIT OR Apache-2.0
License: ASL 2.0 or MIT
URL: https://crates.io/crates/gimli URL: https://crates.io/crates/gimli
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * exclude test fixtures from installed files
Patch: gimli-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Library for reading and writing the DWARF debugging format.} Library for reading and writing the DWARF debugging format.}
@ -34,10 +36,12 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license %{crate_instdir}/LICENSE-APACHE
%doc CHANGELOG.md CONTRIBUTING.md README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CHANGELOG.md
%exclude %{cargo_registry}/%{crate}-%{version_no_tilde}/fixtures/ %doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -49,7 +53,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+endian-reader-devel %package -n %{name}+endian-reader-devel
Summary: %{summary} Summary: %{summary}
@ -61,7 +65,7 @@ This package contains library source intended for building other packages which
use the "endian-reader" feature of the "%{crate}" crate. use the "endian-reader" feature of the "%{crate}" crate.
%files -n %{name}+endian-reader-devel %files -n %{name}+endian-reader-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fallible-iterator-devel %package -n %{name}+fallible-iterator-devel
Summary: %{summary} Summary: %{summary}
@ -73,7 +77,7 @@ This package contains library source intended for building other packages which
use the "fallible-iterator" feature of the "%{crate}" crate. use the "fallible-iterator" feature of the "%{crate}" crate.
%files -n %{name}+fallible-iterator-devel %files -n %{name}+fallible-iterator-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+indexmap-devel %package -n %{name}+indexmap-devel
Summary: %{summary} Summary: %{summary}
@ -85,7 +89,7 @@ This package contains library source intended for building other packages which
use the "indexmap" feature of the "%{crate}" crate. use the "indexmap" feature of the "%{crate}" crate.
%files -n %{name}+indexmap-devel %files -n %{name}+indexmap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+read-devel %package -n %{name}+read-devel
Summary: %{summary} Summary: %{summary}
@ -97,7 +101,7 @@ This package contains library source intended for building other packages which
use the "read" feature of the "%{crate}" crate. use the "read" feature of the "%{crate}" crate.
%files -n %{name}+read-devel %files -n %{name}+read-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+read-core-devel %package -n %{name}+read-core-devel
Summary: %{summary} Summary: %{summary}
@ -109,7 +113,7 @@ This package contains library source intended for building other packages which
use the "read-core" feature of the "%{crate}" crate. use the "read-core" feature of the "%{crate}" crate.
%files -n %{name}+read-core-devel %files -n %{name}+read-core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+stable_deref_trait-devel %package -n %{name}+stable_deref_trait-devel
Summary: %{summary} Summary: %{summary}
@ -121,7 +125,7 @@ This package contains library source intended for building other packages which
use the "stable_deref_trait" feature of the "%{crate}" crate. use the "stable_deref_trait" feature of the "%{crate}" crate.
%files -n %{name}+stable_deref_trait-devel %files -n %{name}+stable_deref_trait-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -133,7 +137,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+write-devel %package -n %{name}+write-devel
Summary: %{summary} Summary: %{summary}
@ -145,7 +149,7 @@ This package contains library source intended for building other packages which
use the "write" feature of the "%{crate}" crate. use the "write" feature of the "%{crate}" crate.
%files -n %{name}+write-devel %files -n %{name}+write-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (gimli-0.26.1.crate) = c341354e13a78c4afeb651a0ed651f60d188957216ba51079512531ab1273b1b79c86c57e904b87064015f8e7efe4280d9edd4acf90e25fb29f8813a4c7bf9a9 SHA512 (gimli-0.26.2.crate) = 10baa5fb5fe13eeab2ed9ac8e02ae7607b42df80b9f39b14027d052ac7f6f11e4dec451bd73c3640ff8ef174e280c1640110720b2bc4220229d27bbb31079029

Loading…
Cancel
Save