Remove alloc feature

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent bdf2a647ba
commit 83bed3b1e0
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,10 @@
--- gimli-0.16.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ gimli-0.16.1/Cargo.toml 2019-02-10T15:17:31.951200+01:00
@@ -65,7 +65,6 @@
version = "1"
[features]
-alloc = ["fallible-iterator/alloc", "stable_deref_trait/alloc"]
default = ["std"]
std = ["fallible-iterator/std", "stable_deref_trait/std"]
[badges.coveralls]

@ -13,6 +13,9 @@ Summary: Blazing fast DWARF debugging format parser
License: ASL 2.0 or MIT
URL: https://crates.io/crates/gimli
Source: %{crates_source}
# Initial patched metadata
# * alloc feature is nightly
Patch0: gimli-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -20,10 +23,8 @@ BuildRequires: rust-packaging
BuildRequires: (crate(arrayvec) >= 0.4.6 with crate(arrayvec) < 0.5.0)
BuildRequires: (crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0)
BuildRequires: (crate(fallible-iterator) >= 0.1.4 with crate(fallible-iterator) < 0.2.0)
BuildRequires: (crate(fallible-iterator/alloc) >= 0.1.4 with crate(fallible-iterator/alloc) < 0.2.0)
BuildRequires: (crate(fallible-iterator/std) >= 0.1.4 with crate(fallible-iterator/std) < 0.2.0)
BuildRequires: (crate(stable_deref_trait) >= 1.1.0 with crate(stable_deref_trait) < 2.0.0)
BuildRequires: (crate(stable_deref_trait/alloc) >= 1.1.0 with crate(stable_deref_trait/alloc) < 2.0.0)
BuildRequires: (crate(stable_deref_trait/std) >= 1.1.0 with crate(stable_deref_trait/std) < 2.0.0)
%if %{with check}
BuildRequires: (crate(crossbeam/default) >= 0.4.1 with crate(crossbeam/default) < 0.5.0)
@ -69,18 +70,6 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch

Loading…
Cancel
Save