Update to version 0.26.1; Fixes RHBZ#2016809

epel9
Fabio Valentini 3 years ago
parent 8305628e7c
commit 5b2a31fc13
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -10,3 +10,4 @@
/gimli-0.23.0.crate
/gimli-0.24.0.crate
/gimli-0.25.0.crate
/gimli-0.26.1.crate

@ -0,0 +1,6 @@
[DEFAULT]
unwanted-features =
alloc
compiler_builtins
core
rustc-dep-of-std

@ -1,30 +0,0 @@
--- gimli-0.25.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ gimli-0.25.0/Cargo.toml 2021-07-28T20:09:30.269078+00:00
@@ -45,19 +45,6 @@
[[example]]
name = "dwarf-validate"
required-features = ["read", "std"]
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
[dependencies.fallible-iterator]
version = "0.2.0"
@@ -104,7 +91,6 @@
default = ["read", "write", "std", "fallible-iterator", "endian-reader"]
endian-reader = ["stable_deref_trait"]
read = []
-rustc-dep-of-std = ["core", "alloc", "compiler_builtins"]
std = ["fallible-iterator/std", "stable_deref_trait/std"]
write = ["indexmap"]
[badges.coveralls]

@ -1,4 +1,4 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 20
# * resolve circular dependency with object and addr2line
%bcond_with check
%global debug_package %{nil}
@ -6,7 +6,7 @@
%global crate gimli
Name: rust-%{crate}
Version: 0.25.0
Version: 0.26.1
Release: %autorelease
Summary: Library for reading and writing the DWARF debugging format
@ -14,14 +14,8 @@ Summary: Library for reading and writing the DWARF debugging format
License: ASL 2.0 or MIT
URL: https://crates.io/crates/gimli
Source: %{crates_source}
# Initial patched metadata
# * drop dependencies on compiler internals
Patch0: gimli-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -36,14 +30,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc CHANGELOG.md CONTRIBUTING.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%exclude %{cargo_registry}/%{crate}-%{version_no_tilde}/{fixtures/,rustfmt.toml}
%exclude %{cargo_registry}/%{crate}-%{version_no_tilde}/fixtures/
%package -n %{name}+default-devel
Summary: %{summary}
@ -51,8 +45,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -63,8 +57,8 @@ BuildArch: noarch
%description -n %{name}+endian-reader-devel %{_description}
This package contains library source intended for building other packages
which use "endian-reader" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "endian-reader" feature of the "%{crate}" crate.
%files -n %{name}+endian-reader-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -75,8 +69,8 @@ BuildArch: noarch
%description -n %{name}+fallible-iterator-devel %{_description}
This package contains library source intended for building other packages
which use "fallible-iterator" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "fallible-iterator" feature of the "%{crate}" crate.
%files -n %{name}+fallible-iterator-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -87,8 +81,8 @@ BuildArch: noarch
%description -n %{name}+indexmap-devel %{_description}
This package contains library source intended for building other packages
which use "indexmap" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "indexmap" feature of the "%{crate}" crate.
%files -n %{name}+indexmap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -99,20 +93,32 @@ BuildArch: noarch
%description -n %{name}+read-devel %{_description}
This package contains library source intended for building other packages
which use "read" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "read" feature of the "%{crate}" crate.
%files -n %{name}+read-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+read-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+read-core-devel %{_description}
This package contains library source intended for building other packages which
use the "read-core" feature of the "%{crate}" crate.
%files -n %{name}+read-core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+stable_deref_trait-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+stable_deref_trait-devel %{_description}
This package contains library source intended for building other packages
which use "stable_deref_trait" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "stable_deref_trait" feature of the "%{crate}" crate.
%files -n %{name}+stable_deref_trait-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -123,8 +129,8 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -135,8 +141,8 @@ BuildArch: noarch
%description -n %{name}+write-devel %{_description}
This package contains library source intended for building other packages
which use "write" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "write" feature of the "%{crate}" crate.
%files -n %{name}+write-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (gimli-0.25.0.crate) = f4e90703b8b7d83c36a63ca7a3d4ee48eec2b0762419780670558c4496ee840489b6a275eb2b635676ba25a010c0e378bae429b54aa4591b9d9868b48e0f0beb
SHA512 (gimli-0.26.1.crate) = c341354e13a78c4afeb651a0ed651f60d188957216ba51079512531ab1273b1b79c86c57e904b87064015f8e7efe4280d9edd4acf90e25fb29f8813a4c7bf9a9

Loading…
Cancel
Save