Update to version 0.28.1; Fixes RHBZ#2231677

epel9 imports/e9/rust-gimli-0.28.1-1.el9
Fabio Valentini 1 year ago
parent d454de4506
commit 3da35ceb48
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/gimli-0.26.2.crate
/gimli-0.27.2.crate
/gimli-0.27.3.crate
/gimli-0.28.1.crate

@ -0,0 +1,35 @@
--- gimli-0.28.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gimli-0.28.1/Cargo.toml 2023-11-29T18:47:33.804255+00:00
@@ -48,20 +48,6 @@
[profile.test]
split-debuginfo = "packed"
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
-
[dependencies.fallible-iterator]
version = "0.3.0"
optional = true
@@ -97,11 +83,6 @@
"endian-reader",
]
read-core = []
-rustc-dep-of-std = [
- "dep:core",
- "dep:alloc",
- "dep:compiler_builtins",
-]
std = [
"fallible-iterator?/std",
"stable_deref_trait?/std",

@ -1,20 +1,22 @@
# Generated by rust2rpm 24
# * resolve circular dependency with object and addr2line
%bcond_with check
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate gimli
Name: rust-gimli
Version: 0.27.3
Version: 0.28.1
Release: %autorelease
Summary: Library for reading and writing the DWARF debugging format
License: MIT OR Apache-2.0
URL: https://crates.io/crates/gimli
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove dependencies on compiler internals
Patch: gimli-fix-metadata.diff
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A library for reading and writing the DWARF debugging format.}
@ -73,18 +75,6 @@ use the "fallible-iterator" feature of the "%{crate}" crate.
%files -n %{name}+fallible-iterator-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+indexmap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+indexmap-devel %{_description}
This package contains library source intended for building other packages which
use the "indexmap" feature of the "%{crate}" crate.
%files -n %{name}+indexmap-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+read-devel
Summary: %{summary}
BuildArch: noarch
@ -97,28 +87,28 @@ use the "read" feature of the "%{crate}" crate.
%files -n %{name}+read-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+read-core-devel
%package -n %{name}+read-all-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+read-core-devel %{_description}
%description -n %{name}+read-all-devel %{_description}
This package contains library source intended for building other packages which
use the "read-core" feature of the "%{crate}" crate.
use the "read-all" feature of the "%{crate}" crate.
%files -n %{name}+read-core-devel
%files -n %{name}+read-all-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+stable_deref_trait-devel
%package -n %{name}+read-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+stable_deref_trait-devel %{_description}
%description -n %{name}+read-core-devel %{_description}
This package contains library source intended for building other packages which
use the "stable_deref_trait" feature of the "%{crate}" crate.
use the "read-core" feature of the "%{crate}" crate.
%files -n %{name}+stable_deref_trait-devel
%files -n %{name}+read-core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
@ -146,7 +136,7 @@ use the "write" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires

@ -1,6 +0,0 @@
[DEFAULT]
unwanted-features =
alloc
compiler_builtins
core
rustc-dep-of-std

@ -1 +1 @@
SHA512 (gimli-0.27.3.crate) = b3782d510bbfcbcfd8801b4343a6864b91cf954808e935745caaf1b7e7b3f2f94814f1543de9a36a8d4e5c29d08d69be9361aa2b31e7a261d5dc6e7b66ef4ccd
SHA512 (gimli-0.28.1.crate) = 695e46471fc07813dc4a47744458729b097f6efbfceeb57eb3db4165654e99bebb98dde2d73230b90bb5dd7c0ca0c6e77c7c3dc6f2abf70058b830a2fb386d25

Loading…
Cancel
Save