initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 94a600a1ca
commit 0b7b7f0a30

1
.gitignore vendored

@ -0,0 +1 @@
/gimli-0.15.0.crate

@ -0,0 +1,34 @@
From 8c4e75bb93a53a97d6ce8bc187cae41432769349 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 3 Dec 2017 21:40:41 +0100
Subject: [PATCH] bump object to 0.6
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
examples/dwarfdump.rs | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/examples/dwarfdump.rs b/examples/dwarfdump.rs
index e6d2050..f601712 100755
--- a/examples/dwarfdump.rs
+++ b/examples/dwarfdump.rs
@@ -9,6 +9,7 @@ extern crate object;
use fallible_iterator::FallibleIterator;
use gimli::UnwindSection;
+use object::Object;
use std::collections::HashMap;
use std::env;
use std::io;
@@ -217,7 +218,7 @@ where
Endian: gimli::Endianity,
'file: 'input,
{
- let data = file.get_section(S::section_name()).unwrap_or(&[]);
+ let data = file.section_data_by_name(S::section_name()).unwrap_or(&[]);
S::from(gimli::EndianBuf::new(data, endian))
}
--
2.15.1

@ -0,0 +1,11 @@
--- gimli-0.15.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ gimli-0.15.0/Cargo.toml 2017-12-03T21:41:30.031228+01:00
@@ -36,7 +36,7 @@
version = "0.6"
[dev-dependencies.object]
-version = "0.5.0"
+version = "0.6"
[dev-dependencies.test-assembler]
version = "0.1.3"

@ -0,0 +1,74 @@
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}
%global crate gimli
Name: rust-%{crate}
Version: 0.15.0
Release: 1%{?dist}
Summary: Blazing fast DWARF debugging format parser
License: ASL 2.0 or MIT
URL: https://crates.io/crates/gimli
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump object to 0.6, https://github.com/gimli-rs/gimli/pull/265
Patch0: gimli-0.15.0-fix-metadata.diff
# Make it work with object-v0.6
Patch1: 0001-bump-object-to-0.6.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(arrayvec) >= 0.4.6 with crate(arrayvec) < 0.5.0)
BuildRequires: (crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0)
BuildRequires: (crate(fallible-iterator) >= 0.1.2 with crate(fallible-iterator) < 0.2.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(getopts) >= 0.2.0 with crate(getopts) < 0.3.0)
BuildRequires: (crate(memmap) >= 0.6.0 with crate(memmap) < 0.7.0)
BuildRequires: (crate(object) >= 0.6.0 with crate(object) < 0.7.0)
BuildRequires: (crate(test-assembler) >= 0.1.3 with crate(test-assembler) < 0.2.0)
%endif
%description
%{summary}.
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
A blazing fast DWARF debugging format parser.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{crate}-%{version} -p1
# https://github.com/gimli-rs/gimli/pull/266
chmod -x benches/bench.rs examples/dwarfdump.rs src/test_util.rs
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc CONTRIBUTING.md README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{coverage,format,releases}
%changelog
* Sun Dec 03 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.15.0-1
- Initial package

@ -0,0 +1 @@
SHA512 (gimli-0.15.0.crate) = 83ab100dda643110166c5c85f0fed46925971d4993311321c887143a2863c23efc13220852fe234b91cd49d9482d6f299ab2b4c39cba2b8176a0271e3a2975f4
Loading…
Cancel
Save