Update to version 0.1.16

epel9 imports/e9/rust-getrandom0.1-0.1.16-1.el9
Fabio Valentini 2 years ago
parent 4247d2edf2
commit 130f01bf15
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/*.src.rpm /*.src.rpm
/getrandom-0.1.15.crate /getrandom-0.1.15.crate
/getrandom-0.1.16.crate

@ -0,0 +1,11 @@
--- getrandom-0.1.16/Cargo.toml 2020-12-31T12:12:09+00:00
+++ getrandom-0.1.16/Cargo.toml 2023-05-18T14:44:12.577132+00:00
@@ -43,8 +43,6 @@
std = []
test-in-browser = ["wasm-bindgen"]
wasm-bindgen = ["bindgen", "js-sys"]
-[target."cfg(target_os = \"wasi\")".dependencies.wasi]
-version = "0.9"
[target."cfg(unix)".dependencies.libc]
version = "0.2.64"
default-features = false

@ -1,18 +1,26 @@
--- getrandom-0.1.15/Cargo.toml 2020-09-10T10:21:20+00:00 --- getrandom-0.1.16/Cargo.toml 2020-12-31T12:12:09+00:00
+++ getrandom-0.1.15/Cargo.toml 2020-11-28T13:48:16.106903+00:00 +++ getrandom-0.1.16/Cargo.toml 2023-05-18T14:44:34.078229+00:00
@@ -42,8 +42,6 @@ @@ -41,25 +41,10 @@
dummy = []
rustc-dep-of-std = ["compiler_builtins", "core"] rustc-dep-of-std = ["compiler_builtins", "core"]
std = [] std = []
test-in-browser = ["wasm-bindgen"] -test-in-browser = ["wasm-bindgen"]
-[target."cfg(target_os = \"wasi\")".dependencies.wasi] -wasm-bindgen = ["bindgen", "js-sys"]
-version = "0.9"
[target."cfg(unix)".dependencies.libc] [target."cfg(unix)".dependencies.libc]
version = "0.2.64" version = "0.2.64"
default-features = false default-features = false
@@ -54,8 +52,6 @@ -[target.wasm32-unknown-unknown.dependencies.bindgen]
[target.wasm32-unknown-unknown.dependencies.wasm-bindgen] -version = "0.2.29"
version = "0.2.29" -optional = true
optional = true -package = "wasm-bindgen"
-[target.wasm32-unknown-unknown.dependencies.js-sys]
-version = "0.3"
-optional = true
-
-[target.wasm32-unknown-unknown.dependencies.stdweb]
-version = "0.4.18"
-optional = true
-[target.wasm32-unknown-unknown.dev-dependencies.wasm-bindgen-test] -[target.wasm32-unknown-unknown.dev-dependencies.wasm-bindgen-test]
-version = "0.2" -version = "0.2"
[badges.appveyor] [badges.appveyor]

@ -1,31 +1,28 @@
# Generated by rust2rpm 16 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate getrandom %global crate getrandom
Name: rust-%{crate}0.1 Name: rust-getrandom0.1
Version: 0.1.15 Version: 0.1.16
Release: %autorelease Release: %autorelease
Summary: Small cross-platform library for retrieving random data from system source Summary: Small cross-platform library for retrieving random data from system source
# Upstream license specification: MIT OR Apache-2.0 License: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/getrandom URL: https://crates.io/crates/getrandom
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Automatically generated patch to strip foreign dependencies
# * No wasi / wasm deps Patch: getrandom-fix-metadata-auto.diff
Patch0: getrandom-fix-metadata.diff # Manually created patch for downstream crate metadata changes
# * drop WASM-specific features and dependencies
Patch: getrandom-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Small cross-platform library for retrieving random data from system source.} A small cross-platform library for retrieving random data from system
source.}
%description %{_description} %description %{_description}
@ -35,13 +32,15 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -49,11 +48,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dummy-devel %package -n %{name}+dummy-devel
Summary: %{summary} Summary: %{summary}
@ -61,11 +60,11 @@ BuildArch: noarch
%description -n %{name}+dummy-devel %{_description} %description -n %{name}+dummy-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "dummy" feature of "%{crate}" crate. use the "dummy" feature of the "%{crate}" crate.
%files -n %{name}+dummy-devel %files -n %{name}+dummy-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel %package -n %{name}+log-devel
Summary: %{summary} Summary: %{summary}
@ -73,11 +72,11 @@ BuildArch: noarch
%description -n %{name}+log-devel %{_description} %description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "log" feature of "%{crate}" crate. use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel %files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -85,11 +84,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description} %description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "std" feature of "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -3,6 +3,3 @@ unwanted-features =
compiler_builtins compiler_builtins
core core
rustc-dep-of-std rustc-dep-of-std
stdweb
test-in-browser
wasm-bindgen

@ -1 +1 @@
SHA512 (getrandom-0.1.15.crate) = b26d9558554058f8a54b03f56f488db5ebad2d5cc84f737e489f8f532f8464ef9038d104173eb30acca61caa1f99e1ce267bc493c01ba1611b829e0a090cc87f SHA512 (getrandom-0.1.16.crate) = c5450c522c07c7a38b326f9a9062bac7d089630219d577ea4b55abad4e0c31d17b7cde385fc43912dfa100b42334e7a52422c55fda8b738caae428c6f9addb53

Loading…
Cancel
Save