commit
410bbccfc4
@ -0,0 +1 @@
|
|||||||
|
SOURCES/generic-array-0.14.7.crate
|
@ -0,0 +1 @@
|
|||||||
|
b7a611ee2caca2842d0ca5285e3e74b8fee37931 SOURCES/generic-array-0.14.7.crate
|
@ -0,0 +1,48 @@
|
|||||||
|
From 58396cbc2d0fe7ca7919e70a0fd0229963f6484a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Thu, 8 Aug 2024 21:37:48 +0200
|
||||||
|
Subject: [PATCH] Skip doctests that don't compile with Rust 1.80+
|
||||||
|
|
||||||
|
---
|
||||||
|
src/arr.rs | 4 ++--
|
||||||
|
src/lib.rs | 2 +-
|
||||||
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/arr.rs b/src/arr.rs
|
||||||
|
index cdcc038..b085043 100644
|
||||||
|
--- a/src/arr.rs
|
||||||
|
+++ b/src/arr.rs
|
||||||
|
@@ -81,7 +81,7 @@ mod doctests_only {
|
||||||
|
/// }
|
||||||
|
/// ```
|
||||||
|
///
|
||||||
|
- /// ```rust
|
||||||
|
+ /// ```compile_fail
|
||||||
|
/// #[macro_use] extern crate generic_array;
|
||||||
|
/// fn main() {
|
||||||
|
/// fn unsound_lifetime_extension<'a, A>(a: &'a A) -> &'a A {
|
||||||
|
@@ -112,7 +112,7 @@ mod doctests_only {
|
||||||
|
/// }
|
||||||
|
/// ```
|
||||||
|
///
|
||||||
|
- /// ```rust
|
||||||
|
+ /// ```compile_fail
|
||||||
|
/// #[macro_use] extern crate generic_array;
|
||||||
|
/// fn main() {
|
||||||
|
/// fn unsound_lifetime_extension<'a, A>(a: &'a A) -> &'a A {
|
||||||
|
diff --git a/src/lib.rs b/src/lib.rs
|
||||||
|
index 14a2797..a4cdf00 100644
|
||||||
|
--- a/src/lib.rs
|
||||||
|
+++ b/src/lib.rs
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
//! Core Rust array types `[T; N]` can't be used generically with
|
||||||
|
//! respect to `N`, so for example this:
|
||||||
|
//!
|
||||||
|
-//! ```rust{compile_fail}
|
||||||
|
+//! ```rust,ignore
|
||||||
|
//! struct Foo<T, N> {
|
||||||
|
//! data: [T; N]
|
||||||
|
//! }
|
||||||
|
--
|
||||||
|
2.46.0
|
||||||
|
|
@ -0,0 +1,201 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 5;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate generic-array
|
||||||
|
|
||||||
|
Name: rust-generic-array
|
||||||
|
Version: 0.14.7
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Generic types implementing functionality of arrays
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/generic-array
|
||||||
|
Source: %{crates_source}
|
||||||
|
# * skip some doctests that fail with syntax errors in Rust 1.80+
|
||||||
|
Patch: 0001-Skip-doctests-that-don-t-compile-with-Rust-1.80.patch
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Generic types implementing functionality of arrays.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+more_lengths-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+more_lengths-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "more_lengths" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+more_lengths-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+zeroize-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+zeroize-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "zeroize" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+zeroize-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# skip some doctests that no longer compile with recent Rust versions
|
||||||
|
%cargo_test -- -- --skip arr::doctests_only::DocTests
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.14.7-5
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Thu Aug 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.14.7-5
|
||||||
|
- Skip some doctests that fail with syntax errors in Rust 1.80+
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.7-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.7-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.7-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 30 2023 Fabio Valentini <decathorpe@gmail.com> - 0.14.7-1
|
||||||
|
- Update to version 0.14.7; Fixes RHBZ#2182226
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.14.6-1
|
||||||
|
- Update to version 0.14.6; Fixes RHBZ#2114215
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.5-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 07 2022 Fabio Valentini <decathorpe@gmail.com> - 0.14.5-1
|
||||||
|
- Update to version 0.14.5; Fixes RHBZ#2037058
|
||||||
|
|
||||||
|
* Fri Jul 30 2021 Fabio Valentini <decathorpe@gmail.com> - 0.14.4-4
|
||||||
|
- Skip some doctests that no longer compile with recent Rust versions.
|
||||||
|
|
||||||
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.4-3
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 20 2020 Josh Stone <jistone@redhat.com> - 0.14.4-1
|
||||||
|
- Update to 0.14.4
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 20 08:31:13 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.14.3-1
|
||||||
|
- Update to 0.14.3
|
||||||
|
|
||||||
|
* Sun Jun 21 09:17:19 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.14.2-1
|
||||||
|
- Update to 0.14.2
|
||||||
|
|
||||||
|
* Thu Feb 20 2020 Josh Stone <jistone@redhat.com> - 0.13.2-1
|
||||||
|
- Update to 0.13.2
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 22 09:18:50 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.0-5
|
||||||
|
- Regenerate
|
||||||
|
|
||||||
|
* Thu Mar 14 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.0-4
|
||||||
|
- Do not pull optional dependencies
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 27 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.0-2
|
||||||
|
- Run tests in infrastructure
|
||||||
|
|
||||||
|
* Sat Sep 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.0-1
|
||||||
|
- Update to 0.12.0
|
||||||
|
|
||||||
|
* Sun Aug 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.1-1
|
||||||
|
- Initial package
|
||||||
|
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue