Update to 0.3.1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent e83de14043
commit ca5fff1925
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -4,3 +4,4 @@
/futures-0.1.21.crate /futures-0.1.21.crate
/futures-0.2.1.crate /futures-0.2.1.crate
/futures-0.2.2.crate /futures-0.2.2.crate
/futures-0.3.1.crate

@ -1,74 +0,0 @@
--- futures-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-preview-0.2.2/Cargo.toml 2018-09-11T07:42:47.547354+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-preview"
+name = "futures"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "An implementation of futures and streams featuring zero allocations,\ncomposability, and iterator-like interfaces.\n"
@@ -25,50 +25,50 @@
[lib]
name = "futures"
-[dependencies.futures-async-runtime-preview]
+[dependencies.futures-async-runtime]
version = "0.2.2"
default-features = false
-[dependencies.futures-channel-preview]
+[dependencies.futures-channel]
version = "0.2.2"
default-features = false
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
-[dependencies.futures-executor-preview]
+[dependencies.futures-executor]
version = "0.2.2"
default-features = false
-[dependencies.futures-io-preview]
+[dependencies.futures-io]
version = "0.2.2"
default-features = false
-[dependencies.futures-macro-async-preview]
+[dependencies.futures-macro-async]
version = "0.2.2"
optional = true
-[dependencies.futures-macro-await-preview]
+[dependencies.futures-macro-await]
version = "0.2.2"
optional = true
-[dependencies.futures-sink-preview]
+[dependencies.futures-sink]
version = "0.2.2"
default-features = false
-[dependencies.futures-stable-preview]
+[dependencies.futures-stable]
version = "0.2.2"
default-features = false
-[dependencies.futures-util-preview]
+[dependencies.futures-util]
version = "0.2.2"
default-features = false
[features]
default = ["std"]
-nightly = ["futures-core-preview/nightly", "futures-stable-preview/nightly", "futures-async-runtime-preview/nightly", "futures-macro-async-preview", "futures-macro-await-preview", "futures-macro-async-preview/nightly"]
-std = ["futures-core-preview/std", "futures-executor-preview/std", "futures-io-preview/std", "futures-sink-preview/std", "futures-stable-preview/std", "futures-util-preview/std", "futures-async-runtime-preview/std"]
+nightly = ["futures-core/nightly", "futures-stable/nightly", "futures-async-runtime/nightly", "futures-macro-async", "futures-macro-await", "futures-macro-async/nightly"]
+std = ["futures-core/std", "futures-executor/std", "futures-io/std", "futures-sink/std", "futures-stable/std", "futures-util/std", "futures-async-runtime/std"]
[badges.appveyor]
repository = "rust-lang-nursery/futures-rs"

@ -1,107 +1,220 @@
# Generated by rust2rpm # Generated by rust2rpm 12
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate futures %global crate futures
%global real_crate futures-preview
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.2 Version: 0.3.1
Release: 2%{?dist} Release: 1%{?dist}
Summary: Implementation of futures and streams featuring zero allocations Summary: Implementation of futures and streams
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-preview URL: https://crates.io/crates/futures
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(futures-async-runtime) >= 0.2.2 with crate(futures-async-runtime) < 0.3.0) %global _description %{expand:
BuildRequires: (crate(futures-channel) >= 0.2.2 with crate(futures-channel) < 0.3.0) Implementation of futures and streams featuring zero allocations,
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0) composability, and iterator-like interfaces.}
BuildRequires: (crate(futures-executor) >= 0.2.2 with crate(futures-executor) < 0.3.0)
BuildRequires: (crate(futures-io) >= 0.2.2 with crate(futures-io) < 0.3.0) %description %{_description}
BuildRequires: (crate(futures-macro-async) >= 0.2.2 with crate(futures-macro-async) < 0.3.0)
BuildRequires: (crate(futures-macro-await) >= 0.2.2 with crate(futures-macro-await) < 0.3.0)
BuildRequires: (crate(futures-sink) >= 0.2.2 with crate(futures-sink) < 0.3.0)
BuildRequires: (crate(futures-stable) >= 0.2.2 with crate(futures-stable) < 0.3.0)
BuildRequires: (crate(futures-util) >= 0.2.2 with crate(futures-util) < 0.3.0)
%description
%{summary}.
%package devel %package devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description devel %description devel %{_description}
An implementation of futures and streams featuring zero allocations,
composability, and iterator-like interfaces.
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use %{crate} from crates.io. which use "%{crate}" crate.
%prep %files devel
%autosetup -n %{real_crate}-%{version} -p1 %license LICENSE-APACHE LICENSE-MIT
%cargo_prep %doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%build %package -n %{name}+default-devel
%cargo_build Summary: %{summary}
BuildArch: noarch
%install %description -n %{name}+default-devel %{_description}
%cargo_install
%if %{with check} This package contains library source intended for building other packages
%check which use "default" feature of "%{crate}" crate.
%cargo_test
%endif
%files devel %files -n %{name}+default-devel
%license LICENSE-MIT LICENSE-APACHE %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%{cargo_registry}/%{crate}-%{version}/
%changelog %package -n %{name}+alloc-devel
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2 Summary: %{summary}
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+async-await-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-await-devel %{_description}
This package contains library source intended for building other packages
which use "async-await" feature of "%{crate}" crate.
%files -n %{name}+async-await-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+bilock-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bilock-devel %{_description}
This package contains library source intended for building other packages
which use "bilock" feature of "%{crate}" crate.
%files -n %{name}+bilock-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+cfg-target-has-atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cfg-target-has-atomic-devel %{_description}
This package contains library source intended for building other packages
which use "cfg-target-has-atomic" feature of "%{crate}" crate.
%files -n %{name}+cfg-target-has-atomic-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+compat-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compat-devel %{_description}
This package contains library source intended for building other packages
which use "compat" feature of "%{crate}" crate.
%files -n %{name}+compat-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1 %package -n %{name}+executor-devel
- Update to 0.2.2 Summary: %{summary}
BuildArch: noarch
%description -n %{name}+executor-devel %{_description}
This package contains library source intended for building other packages
which use "executor" feature of "%{crate}" crate.
%files -n %{name}+executor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+futures-executor-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-executor-devel %{_description}
This package contains library source intended for building other packages
which use "futures-executor" feature of "%{crate}" crate.
%files -n %{name}+futures-executor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+io-compat-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+io-compat-devel %{_description}
This package contains library source intended for building other packages
which use "io-compat" feature of "%{crate}" crate.
%files -n %{name}+io-compat-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+read-initializer-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+read-initializer-devel %{_description}
This package contains library source intended for building other packages
which use "read-initializer" feature of "%{crate}" crate.
%files -n %{name}+read-initializer-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-4 %package -n %{name}+std-devel
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild Summary: %{summary}
BuildArch: noarch
* Sun Jul 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-3 %description -n %{name}+std-devel %{_description}
- Stop ignoring test suite
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+thread-pool-devel
Summary: %{summary}
BuildArch: noarch
* Fri Jun 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-2 %description -n %{name}+thread-pool-devel %{_description}
- Fix build
* Fri May 25 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1 This package contains library source intended for building other packages
- Update to 0.2.1 which use "thread-pool" feature of "%{crate}" crate.
* Tue Apr 03 2018 Josh Stone <jistone@redhat.com> - 0.1.21-1 %files -n %{name}+thread-pool-devel
- Update to 0.1.21 %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
* Fri Mar 23 2018 Josh Stone <jistone@redhat.com> - 0.1.19-1 %package -n %{name}+unstable-devel
- Update to 0.1.19 Summary: %{summary}
BuildArch: noarch
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.18-3 %description -n %{name}+unstable-devel %{_description}
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.18-2 This package contains library source intended for building other packages
- Stop running useless chmod which use "unstable" feature of "%{crate}" crate.
* Fri Jan 26 2018 Josh Stone <jistone@redhat.com> - 0.1.18-1 %files -n %{name}+unstable-devel
- Update to 0.1.18 %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.17-2 %prep
- Rebuild for rust-packaging v5 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.14-1 %generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Sat Dec 14 09:51:49 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-1
- Initial package - Initial package

@ -1 +1 @@
SHA512 (futures-0.2.2.crate) = f305cd45b2fae752f0997826d7c9cf0f1384d0d4b68ab7a8d5396d370635ecf75d3a81ca9db59f66071dff817dcb36139b24f06baf3456670fa10321bdc7b2d5 SHA512 (futures-0.3.1.crate) = 89f2bfd875debd4ac9e355d588f9b129d0a0c7f82b163f7f68f07de183546e4ee4c174e5d01fa6605cdb78b66f65ec63973bb11327f25b51fd67ba83f49958fb

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-futures
Loading…
Cancel
Save