Update to version 0.3.16; Fixes RHBZ#1985526

epel9
Fabio Valentini 4 years ago
parent 184b4d6abb
commit ac491ec1bf
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -17,3 +17,4 @@
/futures-0.3.13.crate
/futures-0.3.14.crate
/futures-0.3.15.crate
/futures-0.3.16.crate

@ -1,11 +1,11 @@
--- futures-0.3.15/Cargo.toml 1970-01-01T00:00:00+00:00
+++ futures-0.3.15/Cargo.toml 2021-05-27T12:24:21.308379+00:00
@@ -62,6 +62,9 @@
--- futures-0.3.16/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.16/Cargo.toml 2021-07-28T13:02:21.873044+00:00
@@ -61,6 +61,9 @@
[dev-dependencies.assert_matches]
version = "1.3.0"
+[dev-dependencies.futures-test]
+version = "0.3.15"
+version = "0.3.16"
+
[dev-dependencies.pin-project]
version = "1.0.1"

@ -1,11 +1,12 @@
# Generated by rust2rpm 17
%bcond_without check
# Generated by rust2rpm 18
# * tests depend on nightly-only features of futures-util
%bcond_with check
%global debug_package %{nil}
%global crate futures
Name: rust-%{crate}
Version: 0.3.15
Version: 0.3.16
Release: %autorelease
Summary: Implementation of futures and streams
@ -216,23 +217,17 @@ which use "write-all-vectored" feature of "%{crate}" crate.
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
%cargo_generate_buildrequires
%build
%cargo_build -a
%cargo_build
%install
%cargo_install -a
%cargo_install
%if %{with check}
%check
%ifarch %{arm} %{ix86}
# ignore two test failures caused by hardcoded result expecting 64-bit pointers
# https://github.com/rust-lang/futures-rs/issues/2446
%cargo_test -a -- -- --skip select_size --skip select_on_non_unpin_size
%else
%cargo_test -a
%endif
%cargo_test
%endif
%changelog

@ -1 +1 @@
SHA512 (futures-0.3.15.crate) = 75a9f0f16c693a1a24d5aaff57aba72abf4f2cd74cb335d905a42e31b9ea20ea0e8fb24e4685d39239f3b7df8a78b13944c04f208798f43249db5e8a36a7affb
SHA512 (futures-0.3.16.crate) = 57a58ede8599cc61fcbe555c84df312aa890ea993ba956759ec8effb71982fad668f024c536dbd20856388d6ceb93841de6c063e5321affcd41e96fddf7a9a0a

Loading…
Cancel
Save