Drop unused compat support for tokio 0.1

epel10
Fabio Valentini 6 months ago
parent 35c0c86143
commit 87df4febaf
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -0,0 +1,24 @@
From 93f1802ce721d4eaf170b04237488b76312e5d8a Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Sun, 1 Sep 2024 02:28:28 +0200
Subject: [PATCH] Fix compiling tests with io-compat feature removed
---
tests/_require_features.rs | 1 -
1 file changed, 1 deletion(-)
diff --git a/tests/_require_features.rs b/tests/_require_features.rs
index 8046cc9..21e2b68 100644
--- a/tests/_require_features.rs
+++ b/tests/_require_features.rs
@@ -3,7 +3,6 @@
feature = "alloc",
feature = "async-await",
feature = "compat",
- feature = "io-compat",
feature = "executor",
feature = "thread-pool",
)))]
--
2.46.0

@ -1,5 +1,5 @@
--- futures-0.3.30/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.30/Cargo.toml 2023-12-27T21:28:33.470398+00:00
+++ futures-0.3.30/Cargo.toml 2024-09-01T00:15:31.426758+00:00
@@ -80,6 +80,9 @@
[dev-dependencies.assert_matches]
version = "1.3.0"
@ -10,3 +10,24 @@
[dev-dependencies.pin-project]
version = "1.0.11"
@@ -88,9 +91,6 @@
[dev-dependencies.static_assertions]
version = "1"
-
-[dev-dependencies.tokio]
-version = "0.1.11"
[features]
alloc = [
@@ -119,10 +119,6 @@
"std",
"futures-executor/std",
]
-io-compat = [
- "compat",
- "futures-util/io-compat",
-]
std = [
"alloc",
"futures-core/std",

@ -1,4 +1,4 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
@ -14,7 +14,9 @@ URL: https://crates.io/crates/futures
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * add missing futures-test dev-dependency
# * drop unused compat support for tokio 0.1
Patch: futures-fix-metadata.diff
Patch: 0001-Fix-compiling-tests-with-io-compat-feature-removed.patch
BuildRequires: cargo-rpm-macros >= 24
@ -135,18 +137,6 @@ use the "futures-executor" feature of the "%{crate}" crate.
%files -n %{name}+futures-executor-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+io-compat-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+io-compat-devel %{_description}
This package contains library source intended for building other packages which
use the "io-compat" feature of the "%{crate}" crate.
%files -n %{name}+io-compat-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
@ -198,6 +188,8 @@ use the "write-all-vectored" feature of the "%{crate}" crate.
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# drop single test that depends on tokio 0.1
rm tests/compat.rs
%generate_buildrequires
%cargo_generate_buildrequires -a

Loading…
Cancel
Save