Update to version 0.3.25; Fixes RHBZ#2136363

epel9
Fabio Valentini 2 years ago
parent 63524cc537
commit 77998fccd2
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -24,3 +24,4 @@
/futures-0.3.21.crate /futures-0.3.21.crate
/futures-0.3.23.crate /futures-0.3.23.crate
/futures-0.3.24.crate /futures-0.3.24.crate
/futures-0.3.25.crate

@ -1,11 +1,11 @@
--- futures-0.3.24/Cargo.toml 1970-01-01T00:00:01+00:00 --- futures-0.3.25/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.24/Cargo.toml 2022-09-06T10:27:12.716695+00:00 +++ futures-0.3.25/Cargo.toml 2022-12-13T15:07:05.349190+00:00
@@ -80,6 +80,9 @@ @@ -80,6 +80,9 @@
[dev-dependencies.assert_matches] [dev-dependencies.assert_matches]
version = "1.3.0" version = "1.3.0"
+[dev-dependencies.futures-test] +[dev-dependencies.futures-test]
+version = "=0.3.24" +version = "=0.3.25"
+ +
[dev-dependencies.pin-project] [dev-dependencies.pin-project]
version = "1.0.11" version = "1.0.11"

@ -1,11 +1,11 @@
# Generated by rust2rpm 22 # Generated by rust2rpm 23
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate futures %global crate futures
Name: rust-futures Name: rust-futures
Version: 0.3.24 Version: 0.3.25
Release: %autorelease Release: %autorelease
Summary: Implementation of futures and streams Summary: Implementation of futures and streams
@ -16,8 +16,6 @@ Source: %{crates_source}
# * add missing futures-test dev-dependency # * add missing futures-test dev-dependency
Patch: futures-fix-metadata.diff Patch: futures-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21 BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
@ -200,6 +198,9 @@ use the "write-all-vectored" feature of the "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
# * remove a test that doesn't compile with Rust < 1.63:
# "use of unstable library feature 'future_poll_fn'"
rm tests/future_join.rs
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires -a %cargo_generate_buildrequires -a
@ -215,7 +216,9 @@ use the "write-all-vectored" feature of the "%{crate}" crate.
# * always skip a test that is officially "flaky" # * always skip a test that is officially "flaky"
# * skip a possibly flaky test: # * skip a possibly flaky test:
# https://github.com/rust-lang/futures-rs/issues/2539 # https://github.com/rust-lang/futures-rs/issues/2539
%cargo_test -a -- -- --skip stream_select --skip many_threads # * skip a test which fails depending on Rust version:
# sizes of some structs and enums changed between Rust 1.62 and 1.63
%cargo_test -a -- -- --skip stream_select --skip many_threads --skip join_size
%endif %endif
%changelog %changelog

@ -1 +1 @@
SHA512 (futures-0.3.24.crate) = 91f3f1b121923c239b1e3042048fd420a35506b4c1ed6527bcff0fffa8153049a384c4e0b21d59944327552c094db8de8977036c61127b27948979e0da6df949 SHA512 (futures-0.3.25.crate) = 1b41edee2927cc68da7101fd9ce8616a61b4102bc378429b8b53adbabda584a5e1df98bcdb2b0ec73466c5a51e996dead7b2d286c7025fcafaffe5e64d715997

Loading…
Cancel
Save