Drop unused compat support for futures 0.1

epel10 imports/epel10/rust-futures-0.3.31-2.el10
Fabio Valentini 5 months ago
parent 71244ab09e
commit 42d1727177
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,24 +1,25 @@
From 93f1802ce721d4eaf170b04237488b76312e5d8a Mon Sep 17 00:00:00 2001
From aaf6eab5c13e1d63f33f4ddf5a08ca1140f44959 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Sun, 1 Sep 2024 02:28:28 +0200
Subject: [PATCH] Fix compiling tests with io-compat feature removed
Subject: [PATCH] Fix compiling tests with compat and io-compat feature removed
---
tests/_require_features.rs | 1 -
1 file changed, 1 deletion(-)
tests/_require_features.rs | 2 --
1 file changed, 2 deletions(-)
diff --git a/tests/_require_features.rs b/tests/_require_features.rs
index 8046cc9..21e2b68 100644
index 8046cc9..e04b4ff 100644
--- a/tests/_require_features.rs
+++ b/tests/_require_features.rs
@@ -3,7 +3,6 @@
@@ -2,8 +2,6 @@
feature = "std",
feature = "alloc",
feature = "async-await",
feature = "compat",
- feature = "compat",
- feature = "io-compat",
feature = "executor",
feature = "thread-pool",
)))]
--
2.46.0
2.47.0

@ -1,5 +1,5 @@
--- futures-0.3.31/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.31/Cargo.toml 2024-10-07T20:39:19.834381+00:00
+++ futures-0.3.31/Cargo.toml 2024-10-13T12:15:28.585671+00:00
@@ -72,10 +72,6 @@
path = "tests/bilock.rs"
@ -29,7 +29,18 @@
[features]
alloc = [
@@ -352,10 +348,6 @@
@@ -340,10 +336,6 @@
]
bilock = ["futures-util/bilock"]
cfg-target-has-atomic = []
-compat = [
- "std",
- "futures-util/compat",
-]
default = [
"std",
"async-await",
@@ -352,10 +344,6 @@
executor = [
"std",
"futures-executor/std",

@ -14,9 +14,10 @@ URL: https://crates.io/crates/futures
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * add missing futures-test dev-dependency
# * drop unused compat support for futures 0.1
# * drop unused compat support for tokio 0.1
Patch: futures-fix-metadata.diff
Patch10: 0001-Fix-compiling-tests-with-io-compat-feature-removed.patch
Patch10: 0001-Fix-compiling-tests-with-compat-and-io-compat-featur.patch
BuildRequires: cargo-rpm-macros >= 24
@ -101,18 +102,6 @@ use the "cfg-target-has-atomic" feature of the "%{crate}" crate.
%files -n %{name}+cfg-target-has-atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+compat-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compat-devel %{_description}
This package contains library source intended for building other packages which
use the "compat" feature of the "%{crate}" crate.
%files -n %{name}+compat-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+executor-devel
Summary: %{summary}
BuildArch: noarch

@ -2,12 +2,13 @@
summary = "Implementation of futures and streams"
cargo-toml-patch-comments = [
"add missing futures-test dev-dependency",
"drop unused compat support for futures 0.1",
"drop unused compat support for tokio 0.1",
]
[[package.extra-patches]]
number = 10
file = "0001-Fix-compiling-tests-with-io-compat-feature-removed.patch"
file = "0001-Fix-compiling-tests-with-compat-and-io-compat-featur.patch"
[features]
enable-all = true

Loading…
Cancel
Save