Update to version 0.3.23; Fixes RHBZ#2118122

epel9
Fabio Valentini 3 years ago
parent 657099288a
commit 3238154c80
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -22,3 +22,4 @@
/futures-0.3.18.crate
/futures-0.3.19.crate
/futures-0.3.21.crate
/futures-0.3.23.crate

@ -1,12 +1,12 @@
--- futures-0.3.21/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.21/Cargo.toml 2022-02-07T23:23:36.680712+00:00
@@ -89,6 +89,9 @@
[dev-dependencies.static_assertions]
version = "1"
--- futures-0.3.23/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.23/Cargo.toml 2022-08-16T14:51:53.012315+00:00
@@ -80,6 +80,9 @@
[dev-dependencies.assert_matches]
version = "1.3.0"
+[dev-dependencies.futures-test]
+version = "0.3.21"
+version = "=0.3.23"
+
[dev-dependencies.tokio]
version = "0.1.11"
[dev-dependencies.pin-project]
version = "1.0.11"

@ -1,25 +1,24 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate futures
Name: rust-%{crate}
Version: 0.3.21
Name: rust-futures
Version: 0.3.23
Release: %autorelease
Summary: Implementation of futures and streams
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/futures
Source: %{crates_source}
# Initial patched metadata
# Manually created patch for downstream crate metadata changes
# * add missing futures-test dev-dependency
Patch0: futures-fix-metadata.diff
Patch: futures-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Implementation of futures and streams featuring zero allocations,
@ -37,8 +36,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,7 +51,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
@ -62,7 +63,7 @@ This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-await-devel
Summary: %{summary}
@ -74,7 +75,7 @@ This package contains library source intended for building other packages which
use the "async-await" feature of the "%{crate}" crate.
%files -n %{name}+async-await-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bilock-devel
Summary: %{summary}
@ -86,7 +87,7 @@ This package contains library source intended for building other packages which
use the "bilock" feature of the "%{crate}" crate.
%files -n %{name}+bilock-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cfg-target-has-atomic-devel
Summary: %{summary}
@ -98,7 +99,7 @@ This package contains library source intended for building other packages which
use the "cfg-target-has-atomic" feature of the "%{crate}" crate.
%files -n %{name}+cfg-target-has-atomic-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+compat-devel
Summary: %{summary}
@ -110,7 +111,7 @@ This package contains library source intended for building other packages which
use the "compat" feature of the "%{crate}" crate.
%files -n %{name}+compat-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+executor-devel
Summary: %{summary}
@ -122,7 +123,7 @@ This package contains library source intended for building other packages which
use the "executor" feature of the "%{crate}" crate.
%files -n %{name}+executor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-executor-devel
Summary: %{summary}
@ -134,7 +135,7 @@ This package contains library source intended for building other packages which
use the "futures-executor" feature of the "%{crate}" crate.
%files -n %{name}+futures-executor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+io-compat-devel
Summary: %{summary}
@ -146,7 +147,7 @@ This package contains library source intended for building other packages which
use the "io-compat" feature of the "%{crate}" crate.
%files -n %{name}+io-compat-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -158,7 +159,7 @@ This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+thread-pool-devel
Summary: %{summary}
@ -170,7 +171,7 @@ This package contains library source intended for building other packages which
use the "thread-pool" feature of the "%{crate}" crate.
%files -n %{name}+thread-pool-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
@ -182,7 +183,7 @@ This package contains library source intended for building other packages which
use the "unstable" feature of the "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+write-all-vectored-devel
Summary: %{summary}
@ -194,7 +195,7 @@ This package contains library source intended for building other packages which
use the "write-all-vectored" feature of the "%{crate}" crate.
%files -n %{name}+write-all-vectored-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -0,0 +1,2 @@
[DEFAULT]
all-features = true

@ -1 +1 @@
SHA512 (futures-0.3.21.crate) = 723fc190e4480fd812a852656fa6509a188f0d06adaa1c22ef24ec4afa7688a1c5d3961e5747f0812d073fc672b0e084af6ad5e5c3fac3ea5829466f993ad865
SHA512 (futures-0.3.23.crate) = 75bc61e7d45efc0d0525b50713721072591fef56798de158431c8e869a4d02cacd3b201073171953c68c4c5edcc8879f7bfa6f9f4cbeeeabd03d1cc86d943512

Loading…
Cancel
Save