parent
441b267884
commit
0a26160e7f
@ -1,6 +0,0 @@
|
||||
/futures-0.1.17.crate
|
||||
/futures-0.1.18.crate
|
||||
/futures-0.1.19.crate
|
||||
/futures-0.1.21.crate
|
||||
/futures-0.2.1.crate
|
||||
/futures-0.2.2.crate
|
@ -0,0 +1 @@
|
||||
Switched to -preview for some unknown time
|
@ -1,74 +0,0 @@
|
||||
--- futures-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ futures-preview-0.2.2/Cargo.toml 2018-09-11T07:42:47.547354+02:00
|
||||
@@ -11,7 +11,7 @@
|
||||
# will likely look very different (and much more reasonable)
|
||||
|
||||
[package]
|
||||
-name = "futures-preview"
|
||||
+name = "futures"
|
||||
version = "0.2.2"
|
||||
authors = ["Alex Crichton <alex@alexcrichton.com>"]
|
||||
description = "An implementation of futures and streams featuring zero allocations,\ncomposability, and iterator-like interfaces.\n"
|
||||
@@ -25,50 +25,50 @@
|
||||
|
||||
[lib]
|
||||
name = "futures"
|
||||
-[dependencies.futures-async-runtime-preview]
|
||||
+[dependencies.futures-async-runtime]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.futures-channel-preview]
|
||||
+[dependencies.futures-channel]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.futures-core-preview]
|
||||
+[dependencies.futures-core]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.futures-executor-preview]
|
||||
+[dependencies.futures-executor]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.futures-io-preview]
|
||||
+[dependencies.futures-io]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.futures-macro-async-preview]
|
||||
+[dependencies.futures-macro-async]
|
||||
version = "0.2.2"
|
||||
optional = true
|
||||
|
||||
-[dependencies.futures-macro-await-preview]
|
||||
+[dependencies.futures-macro-await]
|
||||
version = "0.2.2"
|
||||
optional = true
|
||||
|
||||
-[dependencies.futures-sink-preview]
|
||||
+[dependencies.futures-sink]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.futures-stable-preview]
|
||||
+[dependencies.futures-stable]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
-[dependencies.futures-util-preview]
|
||||
+[dependencies.futures-util]
|
||||
version = "0.2.2"
|
||||
default-features = false
|
||||
|
||||
[features]
|
||||
default = ["std"]
|
||||
-nightly = ["futures-core-preview/nightly", "futures-stable-preview/nightly", "futures-async-runtime-preview/nightly", "futures-macro-async-preview", "futures-macro-await-preview", "futures-macro-async-preview/nightly"]
|
||||
-std = ["futures-core-preview/std", "futures-executor-preview/std", "futures-io-preview/std", "futures-sink-preview/std", "futures-stable-preview/std", "futures-util-preview/std", "futures-async-runtime-preview/std"]
|
||||
+nightly = ["futures-core/nightly", "futures-stable/nightly", "futures-async-runtime/nightly", "futures-macro-async", "futures-macro-await", "futures-macro-async/nightly"]
|
||||
+std = ["futures-core/std", "futures-executor/std", "futures-io/std", "futures-sink/std", "futures-stable/std", "futures-util/std", "futures-async-runtime/std"]
|
||||
[badges.appveyor]
|
||||
repository = "rust-lang-nursery/futures-rs"
|
||||
|
@ -1,107 +0,0 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate futures
|
||||
%global real_crate futures-preview
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.2
|
||||
Release: 2%{?dist}
|
||||
Summary: Implementation of futures and streams featuring zero allocations
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/futures-preview
|
||||
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Remove -preview suffix
|
||||
Patch0: futures-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(futures-async-runtime) >= 0.2.2 with crate(futures-async-runtime) < 0.3.0)
|
||||
BuildRequires: (crate(futures-channel) >= 0.2.2 with crate(futures-channel) < 0.3.0)
|
||||
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
|
||||
BuildRequires: (crate(futures-executor) >= 0.2.2 with crate(futures-executor) < 0.3.0)
|
||||
BuildRequires: (crate(futures-io) >= 0.2.2 with crate(futures-io) < 0.3.0)
|
||||
BuildRequires: (crate(futures-macro-async) >= 0.2.2 with crate(futures-macro-async) < 0.3.0)
|
||||
BuildRequires: (crate(futures-macro-await) >= 0.2.2 with crate(futures-macro-await) < 0.3.0)
|
||||
BuildRequires: (crate(futures-sink) >= 0.2.2 with crate(futures-sink) < 0.3.0)
|
||||
BuildRequires: (crate(futures-stable) >= 0.2.2 with crate(futures-stable) < 0.3.0)
|
||||
BuildRequires: (crate(futures-util) >= 0.2.2 with crate(futures-util) < 0.3.0)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
An implementation of futures and streams featuring zero allocations,
|
||||
composability, and iterator-like interfaces.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{real_crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
|
||||
- Update to 0.2.2
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Sun Jul 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-3
|
||||
- Stop ignoring test suite
|
||||
|
||||
* Fri Jun 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-2
|
||||
- Fix build
|
||||
|
||||
* Fri May 25 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
|
||||
- Update to 0.2.1
|
||||
|
||||
* Tue Apr 03 2018 Josh Stone <jistone@redhat.com> - 0.1.21-1
|
||||
- Update to 0.1.21
|
||||
|
||||
* Fri Mar 23 2018 Josh Stone <jistone@redhat.com> - 0.1.19-1
|
||||
- Update to 0.1.19
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.18-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Jan 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.18-2
|
||||
- Stop running useless chmod
|
||||
|
||||
* Fri Jan 26 2018 Josh Stone <jistone@redhat.com> - 0.1.18-1
|
||||
- Update to 0.1.18
|
||||
|
||||
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.17-2
|
||||
- Rebuild for rust-packaging v5
|
||||
|
||||
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.14-1
|
||||
- Initial package
|
Loading…
Reference in new issue