parent
a421c6c288
commit
90b7648b06
@ -1,2 +0,0 @@
|
|||||||
/futures-util-0.2.1.crate
|
|
||||||
/futures-util-0.2.2.crate
|
|
@ -0,0 +1 @@
|
|||||||
|
Switched to -preview for some unknown time
|
@ -1,41 +0,0 @@
|
|||||||
--- futures-util-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
|
|
||||||
+++ futures-util-preview-0.2.2/Cargo.toml 2018-09-11T07:23:42.837228+02:00
|
|
||||||
@@ -11,7 +11,7 @@
|
|
||||||
# will likely look very different (and much more reasonable)
|
|
||||||
|
|
||||||
[package]
|
|
||||||
-name = "futures-util-preview"
|
|
||||||
+name = "futures-util"
|
|
||||||
version = "0.2.2"
|
|
||||||
authors = ["Alex Crichton <alex@alexcrichton.com>"]
|
|
||||||
description = "Common utilities and extension traits for the futures-rs library.\n"
|
|
||||||
@@ -26,23 +26,23 @@
|
|
||||||
version = "1.4"
|
|
||||||
default-features = false
|
|
||||||
|
|
||||||
-[dependencies.futures-channel-preview]
|
|
||||||
+[dependencies.futures-channel]
|
|
||||||
version = "0.2.2"
|
|
||||||
default-features = false
|
|
||||||
|
|
||||||
-[dependencies.futures-core-preview]
|
|
||||||
+[dependencies.futures-core]
|
|
||||||
version = "0.2.2"
|
|
||||||
default-features = false
|
|
||||||
|
|
||||||
-[dependencies.futures-io-preview]
|
|
||||||
+[dependencies.futures-io]
|
|
||||||
version = "0.2.2"
|
|
||||||
default-features = false
|
|
||||||
|
|
||||||
-[dependencies.futures-sink-preview]
|
|
||||||
+[dependencies.futures-sink]
|
|
||||||
version = "0.2.2"
|
|
||||||
default-features = false
|
|
||||||
|
|
||||||
[features]
|
|
||||||
bench = []
|
|
||||||
-default = ["std", "futures-core-preview/either", "futures-sink-preview/either"]
|
|
||||||
-std = ["futures-core-preview/std", "futures-io-preview/std", "futures-sink-preview/std", "either/use_std"]
|
|
||||||
+default = ["std", "futures-core/either", "futures-sink/either"]
|
|
||||||
+std = ["futures-core/std", "futures-io/std", "futures-sink/std", "either/use_std"]
|
|
@ -1,76 +0,0 @@
|
|||||||
# Generated by rust2rpm
|
|
||||||
# * Tests do not work out of the tree
|
|
||||||
# https://github.com/rust-lang-nursery/futures-rs/issues/1019
|
|
||||||
%bcond_with check
|
|
||||||
%global debug_package %{nil}
|
|
||||||
|
|
||||||
%global crate futures-util
|
|
||||||
%global real_crate futures-util-preview
|
|
||||||
|
|
||||||
Name: rust-%{crate}
|
|
||||||
Version: 0.2.2
|
|
||||||
Release: 2%{?dist}
|
|
||||||
Summary: Common utilities and extension traits for the futures-rs library
|
|
||||||
|
|
||||||
# Upstream license specification: MIT/Apache-2.0
|
|
||||||
License: MIT or ASL 2.0
|
|
||||||
URL: https://crates.io/crates/futures-util-preview
|
|
||||||
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
|
|
||||||
# Initial patched metadata
|
|
||||||
# * Remove -preview suffix
|
|
||||||
Patch0: futures-util-fix-metadata.diff
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
|
||||||
|
|
||||||
BuildRequires: rust-packaging
|
|
||||||
# [dependencies]
|
|
||||||
BuildRequires: (crate(either) >= 1.4.0 with crate(either) < 2.0.0)
|
|
||||||
BuildRequires: (crate(futures-channel) >= 0.2.2 with crate(futures-channel) < 0.3.0)
|
|
||||||
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
|
|
||||||
BuildRequires: (crate(futures-io) >= 0.2.2 with crate(futures-io) < 0.3.0)
|
|
||||||
BuildRequires: (crate(futures-sink) >= 0.2.2 with crate(futures-sink) < 0.3.0)
|
|
||||||
|
|
||||||
%description
|
|
||||||
%{summary}.
|
|
||||||
|
|
||||||
%package devel
|
|
||||||
Summary: %{summary}
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
%description devel
|
|
||||||
Common utilities and extension traits for the futures-rs library.
|
|
||||||
|
|
||||||
This package contains library source intended for building other packages
|
|
||||||
which use %{crate} from crates.io.
|
|
||||||
|
|
||||||
%prep
|
|
||||||
%autosetup -n %{real_crate}-%{version} -p1
|
|
||||||
%cargo_prep
|
|
||||||
|
|
||||||
%build
|
|
||||||
%cargo_build
|
|
||||||
|
|
||||||
%install
|
|
||||||
%cargo_install
|
|
||||||
|
|
||||||
%if %{with check}
|
|
||||||
%check
|
|
||||||
%cargo_test
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%files devel
|
|
||||||
%license LICENSE-MIT LICENSE-APACHE
|
|
||||||
%{cargo_registry}/%{crate}-%{version}/
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
||||||
|
|
||||||
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
|
|
||||||
- Update to 0.2.2
|
|
||||||
|
|
||||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
|
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
||||||
|
|
||||||
* Mon May 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
|
|
||||||
- Initial package
|
|
Loading…
Reference in new issue