Initial import

Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
epel9
Robert-André Mauchin 5 years ago
parent a7182d0769
commit d587c5b797

1
.gitignore vendored

@ -1,2 +1,3 @@
/futures-sink-0.2.1.crate
/futures-sink-0.2.2.crate
/futures-sink-0.3.1.crate

@ -1,29 +0,0 @@
--- futures-sink-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-sink-preview-0.2.2/Cargo.toml 2018-09-11T00:44:49.368531+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-sink-preview"
+name = "futures-sink"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "The asynchronous `Sink` trait for the futures-rs library.\n"
@@ -27,14 +27,14 @@
optional = true
default-features = false
-[dependencies.futures-channel-preview]
+[dependencies.futures-channel]
version = "0.2.2"
default-features = false
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
[features]
default = ["std"]
-std = ["either/use_std", "futures-core-preview/std", "futures-channel-preview/std"]
+std = ["either/use_std", "futures-core/std", "futures-channel/std"]

@ -1,48 +1,87 @@
# Generated by rust2rpm
# Generated by rust2rpm 11
%bcond_without check
%global debug_package %{nil}
%global crate futures-sink
%global real_crate futures-sink-preview
Name: rust-%{crate}
Version: 0.2.2
Release: 2%{?dist}
Version: 0.3.1
Release: 1%{?dist}
Summary: Asynchronous `Sink` trait for the futures-rs library
# Upstream license specification: MIT/Apache-2.0
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-sink-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-sink-fix-metadata.diff
URL: https://crates.io/crates/futures-sink
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(either) >= 1.4.0 with crate(either) < 2.0.0)
BuildRequires: (crate(futures-channel) >= 0.2.2 with crate(futures-channel) < 0.3.0)
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
%description
%{summary}.
%global _description %{expand:
Asynchronous `Sink` trait for the futures-rs library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
The asynchronous `Sink` trait for the futures-rs library.
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{real_crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -54,19 +93,6 @@ which use %{crate} from crates.io.
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon May 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
* Fri Dec 13 20:45:04 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.1-1
- Initial package

@ -1 +1 @@
SHA512 (futures-sink-0.2.2.crate) = dae3350700ebbbdd09ac0f6392ce77b7b25560d415517d042037432d6b97bca519f6c95c5b178d4a5db8c8f9e76049149964ccd2d1ffd725e2172509193ff9c0
SHA512 (futures-sink-0.3.1.crate) = 3f014b33eb9b45d7111f8e4876b1844ea52c2d746652d0f2a13ee50a42ecb7a5c776afefda046515f9566f50341336245e21b592b3b3c00e4a92eee31e22fa3f

Loading…
Cancel
Save