Initial import

Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
epel9
Robert-André Mauchin 5 years ago
parent f8038895c3
commit fb4de6e24a

1
.gitignore vendored

@ -1,2 +1,3 @@
/futures-io-0.2.1.crate
/futures-io-0.2.2.crate
/futures-io-0.3.1.crate

@ -1,26 +0,0 @@
--- futures-io-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-io-preview-0.2.2/Cargo.toml 2018-09-11T00:22:30.383567+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-io-preview"
+name = "futures-io"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "The `AsyncRead` and `AsyncWrite` traits for the futures-rs library.\n"
@@ -22,7 +22,7 @@
[lib]
name = "futures_io"
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
@@ -32,4 +32,4 @@
[features]
default = ["std"]
-std = ["futures-core-preview/std", "iovec"]
+std = ["futures-core/std", "iovec"]

@ -1,47 +1,99 @@
# Generated by rust2rpm
# Generated by rust2rpm 11
%bcond_without check
%global debug_package %{nil}
%global crate futures-io
%global real_crate futures-io-preview
Name: rust-%{crate}
Version: 0.2.2
Release: 2%{?dist}
Version: 0.3.1
Release: 1%{?dist}
Summary: `AsyncRead` and `AsyncWrite` traits for the futures-rs library
# Upstream license specification: MIT/Apache-2.0
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-io-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-io-fix-metadata.diff
URL: https://crates.io/crates/futures-io
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
BuildRequires: (crate(iovec) >= 0.1.0 with crate(iovec) < 0.2.0)
%description
%{summary}.
%global _description %{expand:
`AsyncRead` and `AsyncWrite` traits for the futures-rs library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
The `AsyncRead` and `AsyncWrite` traits for the futures-rs library.
%description devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+read-initializer-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+read-initializer-devel %{_description}
This package contains library source intended for building other packages
which use "read-initializer" feature of "%{crate}" crate.
%files -n %{name}+read-initializer-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unstable-devel %{_description}
This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{real_crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -53,19 +105,6 @@ which use %{crate} from crates.io.
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon May 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
* Fri Dec 13 20:50:48 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.1-1
- Initial package

@ -1 +1 @@
SHA512 (futures-io-0.2.2.crate) = 15867e00a4a43932709f593006353ad9eab8b76c1c85bf54399a4fd35497f30d64b3d6529d1b866ac1d78c02d36039558e4697eaf96f1a65464dcd948413a993
SHA512 (futures-io-0.3.1.crate) = c4febd39793fc7e4b2a2750375b0d9b89ed7ff0c90a3502d9abc0ad1993fbee752d29f1196f63b35061ee883cd78d11a2b30211fcc98b9fed490321050dff327

Loading…
Cancel
Save