Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent e3b73e0141
commit e5897c4ff4
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1,2 +1,3 @@
/futures-executor-0.2.1.crate
/futures-executor-0.2.2.crate
/futures-executor-0.3.1.crate

@ -1,36 +0,0 @@
--- futures-executor-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-executor-preview-0.2.2/Cargo.toml 2018-09-11T07:36:33.910718+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-executor-preview"
+name = "futures-executor"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "Executors for asynchronous tasks based on the futures-rs library.\n"
@@ -22,15 +22,15 @@
[lib]
name = "futures_executor"
-[dependencies.futures-channel-preview]
+[dependencies.futures-channel]
version = "0.2.2"
default-features = false
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
-[dependencies.futures-util-preview]
+[dependencies.futures-util]
version = "0.2.2"
default-features = false
@@ -44,4 +44,4 @@
[features]
default = ["std"]
-std = ["num_cpus", "futures-core-preview/std", "futures-util-preview/std", "futures-channel-preview/std", "lazy_static"]
+std = ["num_cpus", "futures-core/std", "futures-util/std", "futures-channel/std", "lazy_static"]

@ -1,52 +1,99 @@
# Generated by rust2rpm
# * Tests do not work out of the tree
# https://github.com/rust-lang-nursery/futures-rs/issues/1020
%bcond_with check
# Generated by rust2rpm 12
%bcond_without check
%global debug_package %{nil}
%global crate futures-executor
%global real_crate futures-executor-preview
Name: rust-%{crate}
Version: 0.2.2
Release: 2%{?dist}
Version: 0.3.1
Release: 1%{?dist}
Summary: Executors for asynchronous tasks based on the futures-rs library
# Upstream license specification: MIT/Apache-2.0
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-executor-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-executor-fix-metadata.diff
URL: https://crates.io/crates/futures-executor
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(futures-channel) >= 0.2.2 with crate(futures-channel) < 0.3.0)
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
BuildRequires: (crate(futures-util) >= 0.2.2 with crate(futures-util) < 0.3.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(num_cpus) >= 1.0.0 with crate(num_cpus) < 2.0.0)
%description
%{summary}.
%global _description %{expand:
Executors for asynchronous tasks based on the futures-rs library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
Executors for asynchronous tasks based on the futures-rs library.
%description devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+num_cpus-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+num_cpus-devel %{_description}
This package contains library source intended for building other packages
which use "num_cpus" feature of "%{crate}" crate.
%files -n %{name}+num_cpus-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+thread-pool-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+thread-pool-devel %{_description}
This package contains library source intended for building other packages
which use "thread-pool" feature of "%{crate}" crate.
%files -n %{name}+thread-pool-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{real_crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -58,19 +105,6 @@ which use %{crate} from crates.io.
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon May 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
* Sat Dec 14 09:57:45 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-1
- Initial package

@ -1 +1 @@
SHA512 (futures-executor-0.2.2.crate) = 0652c916dbcad507d6b2e22100fdca6c290548567b5b124f92f56d3ab65c54775d40f584b3656608d3ff8471fc0ee39f50b7c0059ddac515950a1b7590631ee8
SHA512 (futures-executor-0.3.1.crate) = 26036ec8ce2d839cc58502b0a7bb68174a07add5f6662f42a81c1bc3116b04a7def8a9cf95a615aa2b662b30dbe9316630f4588a5634097e5b990e3223550211

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-futures-executor
Loading…
Cancel
Save