You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-futures-executor/futures-executor-fix-metada...

37 lines
1.1 KiB

--- futures-executor-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-executor-preview-0.2.2/Cargo.toml 2018-09-11T07:36:33.910718+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-executor-preview"
+name = "futures-executor"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "Executors for asynchronous tasks based on the futures-rs library.\n"
@@ -22,15 +22,15 @@
[lib]
name = "futures_executor"
-[dependencies.futures-channel-preview]
+[dependencies.futures-channel]
version = "0.2.2"
default-features = false
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
-[dependencies.futures-util-preview]
+[dependencies.futures-util]
version = "0.2.2"
default-features = false
@@ -44,4 +44,4 @@
[features]
default = ["std"]
-std = ["num_cpus", "futures-core-preview/std", "futures-util-preview/std", "futures-channel-preview/std", "lazy_static"]
+std = ["num_cpus", "futures-core/std", "futures-util/std", "futures-channel/std", "lazy_static"]