Update to 0.2.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 46bf94bae2
commit 827c159e2f
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/futures-channel-0.2.1.crate
/futures-channel-0.2.2.crate

@ -0,0 +1,24 @@
--- futures-channel-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-channel-preview-0.2.2/Cargo.toml 2018-09-11T00:25:14.248096+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-channel-preview"
+name = "futures-channel"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "Channels for asynchronous communication using futures-rs.\n"
@@ -22,10 +22,10 @@
[lib]
name = "futures_channel"
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
[features]
default = ["std"]
-std = ["futures-core-preview/std"]
+std = ["futures-core/std"]

@ -5,22 +5,26 @@
%global debug_package %{nil}
%global crate futures-channel
%global real_crate futures-channel-preview
Name: rust-%{crate}
Version: 0.2.1
Release: 2%{?dist}
Version: 0.2.2
Release: 1%{?dist}
Summary: Channels for asynchronous communication using futures-rs
# https://github.com/rust-lang-nursery/futures-rs/issues/1015
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-channel
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
URL: https://crates.io/crates/futures-channel-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-channel-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(futures-core) >= 0.2.1 with crate(futures-core) < 0.3.0)
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
%description
%{summary}.
@ -36,9 +40,7 @@ This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{crate}-%{version} -p1
# https://github.com/rust-lang-nursery/futures-rs/pull/1016
find -type f -name '*.rs' -executable -print -exec chmod -x {} +
%autosetup -n %{real_crate}-%{version} -p1
%cargo_prep
%build
@ -53,9 +55,13 @@ find -type f -name '*.rs' -executable -print -exec chmod -x {} +
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1 +1 @@
SHA512 (futures-channel-0.2.1.crate) = 1fbfc50778fdb70f6894e0c393e5313e04d9af66ab694366b001800174841f447ff7cef1fffb043f394aa8c4d72e0f553b06fd92dcd4bd4b0a4f0f1036cf4f72
SHA512 (futures-channel-0.2.2.crate) = 90d9f041926084727f1ee72c5354563ed6cbb1ff3e8abe0fa0c5ecd477c0669c1d3df1074920a5750c1a463a6bb615d6c1972e7a4af43286572a33ab970fe835

Loading…
Cancel
Save