parent
1930a22d3a
commit
61b8c0ee12
@ -0,0 +1 @@
|
||||
/fs2-0.4.3.crate
|
@ -0,0 +1,12 @@
|
||||
--- fs2-0.4.3/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ fs2-0.4.3/Cargo.toml 2018-01-13T17:57:17.249853+01:00
|
||||
@@ -23,9 +23,6 @@
|
||||
version = "0.3"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2.30"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["handleapi", "processthreadsapi", "winerror", "fileapi", "winbase", "std"]
|
||||
[badges.appveyor]
|
||||
repository = "danburkert/fs2-rs"
|
||||
|
@ -0,0 +1,65 @@
|
||||
# Generated by rust2rpm
|
||||
# * Tests require nightly compiler
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate fs2
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.4.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross-platform file locks and file duplication
|
||||
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/fs2
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No windows
|
||||
Patch0: fs2-0.4.3-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(libc) >= 0.2.30 with crate(libc) < 0.3.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Cross-platform file locks and file duplication.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Sat Jan 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.3-1
|
||||
- Initial package
|
Loading…
Reference in new issue