parent
9e3a278028
commit
243b35c0ab
@ -0,0 +1 @@
|
||||
/foldhash-0.1.3.crate
|
@ -0,0 +1,12 @@
|
||||
--- foldhash-0.1.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ foldhash-0.1.3/Cargo.toml 2024-10-07T17:53:38.984364+00:00
|
||||
@@ -54,9 +54,6 @@
|
||||
[dev-dependencies.chrono]
|
||||
version = "0.4"
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.5"
|
||||
-
|
||||
[dev-dependencies.fxhash]
|
||||
version = "0.2"
|
||||
|
@ -0,0 +1,83 @@
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate foldhash
|
||||
|
||||
Name: rust-foldhash
|
||||
Version: 0.1.3
|
||||
Release: %autorelease
|
||||
Summary: Fast, non-cryptographic, minimally DoS-resistant hashing algorithm
|
||||
|
||||
License: Zlib
|
||||
URL: https://crates.io/crates/foldhash
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
Patch: foldhash-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A fast, non-cryptographic, minimally DoS-resistant hashing algorithm.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,5 @@
|
||||
[package]
|
||||
cargo-toml-patch-comments = [
|
||||
"drop unused, benchmark-only criterion dev-dependency",
|
||||
]
|
||||
|
Loading…
Reference in new issue