Update to 0.10.14

epel10
Orion Poplawski 2 years ago
parent 22fbfd88cf
commit 6bc2de719b

1
.gitignore vendored

@ -2,3 +2,4 @@
/flume-0.7.2.crate /flume-0.7.2.crate
/flume-0.9.0.crate /flume-0.9.0.crate
/flume-0.9.1.crate /flume-0.9.1.crate
/flume-0.10.14.crate

@ -0,0 +1,13 @@
diff -up flume-0.10.14/Cargo.toml.criterion flume-0.10.14/Cargo.toml
--- flume-0.10.14/Cargo.toml.criterion 1969-12-31 17:00:01.000000000 -0700
+++ flume-0.10.14/Cargo.toml 2022-10-19 08:48:19.949933517 -0600
@@ -69,9 +69,6 @@ features = [
"unstable",
]
-[dev-dependencies.criterion]
-version = "0.3.4"
-
[dev-dependencies.crossbeam-channel]
version = "0.5.5"

@ -1,27 +1,24 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 22
# * async-std is not packaged %bcond_without check
# * criterion is too old (0.3.1+)
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate flume %global crate flume
Name: rust-%{crate} Name: rust-flume
Version: 0.9.1 Version: 0.10.14
Release: 3%{?dist} Release: %autorelease
Summary: Blazingly fast multi-producer channel Summary: Blazingly fast multi-producer channel
# Upstream license specification: Apache-2.0/MIT # Upstream license specification: Apache-2.0/MIT
License: ASL 2.0 or MIT License: Apache-2.0 OR MIT
URL: https://crates.io/crates/flume URL: https://crates.io/crates/flume
Source: %{crates_source} Source: %{crates_source}
# Remove criterion dev dependency
Patch: rust-flume-criterion.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Blazingly fast multi-producer channel.} Blazingly fast multi-producer channel.}
@ -34,13 +31,15 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -48,11 +47,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-devel %package -n %{name}+async-devel
Summary: %{summary} Summary: %{summary}
@ -60,11 +59,11 @@ BuildArch: noarch
%description -n %{name}+async-devel %{_description} %description -n %{name}+async-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "async" feature of "%{crate}" crate. use the "async" feature of the "%{crate}" crate.
%files -n %{name}+async-devel %files -n %{name}+async-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+eventual-fairness-devel %package -n %{name}+eventual-fairness-devel
Summary: %{summary} Summary: %{summary}
@ -72,11 +71,11 @@ BuildArch: noarch
%description -n %{name}+eventual-fairness-devel %{_description} %description -n %{name}+eventual-fairness-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "eventual-fairness" feature of "%{crate}" crate. use the "eventual-fairness" feature of the "%{crate}" crate.
%files -n %{name}+eventual-fairness-devel %files -n %{name}+eventual-fairness-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-core-devel %package -n %{name}+futures-core-devel
Summary: %{summary} Summary: %{summary}
@ -84,11 +83,11 @@ BuildArch: noarch
%description -n %{name}+futures-core-devel %{_description} %description -n %{name}+futures-core-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "futures-core" feature of "%{crate}" crate. use the "futures-core" feature of the "%{crate}" crate.
%files -n %{name}+futures-core-devel %files -n %{name}+futures-core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-sink-devel %package -n %{name}+futures-sink-devel
Summary: %{summary} Summary: %{summary}
@ -96,23 +95,35 @@ BuildArch: noarch
%description -n %{name}+futures-sink-devel %{_description} %description -n %{name}+futures-sink-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "futures-sink" feature of "%{crate}" crate. use the "futures-sink" feature of the "%{crate}" crate.
%files -n %{name}+futures-sink-devel %files -n %{name}+futures-sink-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nanorand-devel
Summary: %{summary}
BuildArch: noarch
%package -n %{name}+rand-devel %description -n %{name}+nanorand-devel %{_description}
This package contains library source intended for building other packages which
use the "nanorand" feature of the "%{crate}" crate.
%files -n %{name}+nanorand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pin-project-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+rand-devel %{_description} %description -n %{name}+pin-project-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "rand" feature of "%{crate}" crate. use the "pin-project" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel %files -n %{name}+pin-project-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+select-devel %package -n %{name}+select-devel
Summary: %{summary} Summary: %{summary}
@ -120,11 +131,23 @@ BuildArch: noarch
%description -n %{name}+select-devel %{_description} %description -n %{name}+select-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "select" feature of "%{crate}" crate. use the "select" feature of the "%{crate}" crate.
%files -n %{name}+select-devel %files -n %{name}+select-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+spin-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+spin-devel %{_description}
This package contains library source intended for building other packages which
use the "spin" feature of the "%{crate}" crate.
%files -n %{name}+spin-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -145,23 +168,4 @@ which use "select" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.1-3 %autochangelog
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.9.1-1
- Update to version 0.9.1.
* Wed Sep 23 2020 Fabio Valentini <decathorpe@gmail.com> - 0.9.0-1
- Update to version 0.9.0.
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jul 22 2020 Josh Stone <jistone@redhat.com> - 0.7.2-1
- Update to 0.7.2
* Mon Mar 30 08:14:25 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.7.1-1
- Initial package

@ -1 +1 @@
SHA512 (flume-0.9.1.crate) = c2d24c794cf35e542cfe2ba3a2f782adba83e7d12661f98da68da831693bf67b1ce6bd534129275de46c7907b0c5e2fc9bea37655811493227857609af90e33f SHA512 (flume-0.10.14.crate) = ad31351031683453b77d85a89812304d63a12cce8bbd31dfaa508091cec52bc511739d4d13a085aa8bf9f2438fc1876a99f2e4ab2602bdbfe0d2ebb1df4eab0f

Loading…
Cancel
Save