parent
c0d5e94088
commit
95e3abd872
@ -0,0 +1 @@
|
|||||||
|
/float-ord-0.2.0.crate
|
@ -0,0 +1,51 @@
|
|||||||
|
diff -ru float-ord-0.2.0/Cargo.toml float-ord-0.2.0.patched/Cargo.toml
|
||||||
|
--- float-ord-0.2.0/Cargo.toml 1969-12-31 19:00:00.000000000 -0500
|
||||||
|
+++ float-ord-0.2.0.patched/Cargo.toml 2020-01-28 16:36:06.742269458 -0500
|
||||||
|
@@ -20,6 +20,6 @@
|
||||||
|
license = "MIT / Apache-2.0"
|
||||||
|
repository = "https://github.com/notriddle/rust-float-ord"
|
||||||
|
[dev-dependencies.rand]
|
||||||
|
-version = "0.3"
|
||||||
|
+version = "0.7"
|
||||||
|
[badges.travis-ci]
|
||||||
|
repository = "notriddle/rust-float-ord"
|
||||||
|
diff -ru float-ord-0.2.0/src/lib.rs float-ord-0.2.0.patched/src/lib.rs
|
||||||
|
--- float-ord-0.2.0/src/lib.rs 2018-01-30 14:28:28.000000000 -0500
|
||||||
|
+++ float-ord-0.2.0.patched/src/lib.rs 2020-01-28 17:08:50.441756013 -0500
|
||||||
|
@@ -78,6 +78,7 @@
|
||||||
|
extern crate rand;
|
||||||
|
|
||||||
|
use self::rand::{Rng, thread_rng};
|
||||||
|
+ use self::std::iter;
|
||||||
|
use self::std::prelude::v1::*;
|
||||||
|
use self::std::collections::hash_map::DefaultHasher;
|
||||||
|
use self::std::hash::{Hash, Hasher};
|
||||||
|
@@ -108,8 +109,8 @@
|
||||||
|
let mut rng = thread_rng();
|
||||||
|
for n in 0..16 {
|
||||||
|
for l in 0..16 {
|
||||||
|
- let v = rng.gen_iter::<f64>()
|
||||||
|
- .map(|x| x % (1 << l) as i64 as f64)
|
||||||
|
+ let v = iter::repeat(()).map(|()| rng.gen())
|
||||||
|
+ .map(|x: f64| x % (1 << l) as i64 as f64)
|
||||||
|
.take((1 << n))
|
||||||
|
.collect::<Vec<_>>();
|
||||||
|
assert!(v.windows(2).all(|w| (w[0] <= w[1]) == (FloatOrd(w[0]) <= FloatOrd(w[1]))));
|
||||||
|
@@ -140,14 +141,14 @@
|
||||||
|
let mut rng = thread_rng();
|
||||||
|
for n in 0..16 {
|
||||||
|
for l in 0..16 {
|
||||||
|
- let mut v = rng.gen_iter::<f64>()
|
||||||
|
- .map(|x| x % (1 << l) as i64 as f64)
|
||||||
|
+ let mut v = iter::repeat(()).map(|()| rng.gen())
|
||||||
|
+ .map(|x: f64| x % (1 << l) as i64 as f64)
|
||||||
|
.take((1 << n))
|
||||||
|
.collect::<Vec<_>>();
|
||||||
|
let mut v1 = v.clone();
|
||||||
|
|
||||||
|
super::sort(&mut v);
|
||||||
|
- assert!(v.windows(2).all(|w| w[0] <= w[1]));
|
||||||
|
+ assert!(v.windows(2).all(|w: &[f64]| w[0] <= w[1]));
|
||||||
|
|
||||||
|
v1.sort_by(|a, b| a.partial_cmp(b).unwrap());
|
||||||
|
assert!(v1.windows(2).all(|w| w[0] <= w[1]));
|
@ -0,0 +1,79 @@
|
|||||||
|
# Generated by rust2rpm 13
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate float-ord
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.2.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Total ordering for floating-point numbers
|
||||||
|
|
||||||
|
# Upstream license specification: MIT / Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/float-ord
|
||||||
|
Source: %{crates_source}
|
||||||
|
# https://github.com/notriddle/rust-float-ord/pull/7
|
||||||
|
Patch0: 0000-Update-to-rand-0.7.patch
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: dos2unix
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Total ordering for floating-point numbers.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-APACHE LICENSE-MIT
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
dos2unix README.md
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jan 22 09:44:50 EST 2020 Randy Barlow <randy@electronsweatshop.com> - 0.2.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue