Update to version 1.0.24; Fixes RHBZ#2074155

epel9
Fabio Valentini 3 years ago
parent d34be957f7
commit 8735c9ed44
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/flate2-1.0.20.crate
/flate2-1.0.21.crate
/flate2-1.0.22.crate
/flate2-1.0.24.crate

@ -1,26 +1,10 @@
--- flate2-1.0.22/Cargo.toml 1970-01-01T00:00:01+00:00
+++ flate2-1.0.22/Cargo.toml 2021-09-30T16:19:11.391834+00:00
@@ -24,10 +24,6 @@
repository = "https://github.com/rust-lang/flate2-rs"
[dependencies.cfg-if]
version = "1.0.0"
--- flate2-1.0.24/Cargo.toml 1970-01-01T00:00:01+00:00
+++ flate2-1.0.24/Cargo.toml 2022-08-09T08:55:49.802987+00:00
@@ -88,7 +88,3 @@
"zlib",
"libz-sys/zlib-ng",
]
-
-[dependencies.cloudflare-zlib-sys]
-version = "0.3.0"
-optional = true
[dependencies.crc32fast]
version = "1.2.0"
@@ -77,12 +73,7 @@
[features]
any_zlib = []
-cloudflare_zlib = ["any_zlib", "cloudflare-zlib-sys"]
default = ["rust_backend"]
rust_backend = ["miniz_oxide"]
tokio = ["tokio-io", "futures"]
zlib = ["any_zlib", "libz-sys"]
-zlib-ng-compat = ["zlib", "libz-sys/zlib-ng"]
-[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.miniz_oxide]
-version = "0.4.0"
-version = "0.5.0"
-default-features = false

@ -1,35 +1,29 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate flate2
Name: rust-%{crate}
Version: 1.0.22
Name: rust-flate2
Version: 1.0.24
Release: %autorelease
Summary: DEFLATE compression and decompression exposed as Read/BufRead/Write streams
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/flate2
Source: %{crates_source}
# Initial patched metadata
# * No wasm32
# * No cloudflare-zlib-sys
# * No zlib-ng support in libz-sys
Patch0: flate2-fix-metadata.diff
# Manually created patch for downstream crate metadata changes
# * remove WASM-specific dependencies
Patch: flate2-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
DEFLATE compression and decompression exposed as Read/BufRead/Write streams.
Supports miniz_oxide, miniz.c, and multiple zlib implementations. Supports
zlib, gzip, and raw deflate streams.}
Supports miniz_oxide and multiple zlib implementations. Supports zlib, gzip,
and raw deflate streams.}
%description %{_description}
@ -39,13 +33,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -53,11 +48,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+any_zlib-devel
Summary: %{summary}
@ -65,23 +60,11 @@ BuildArch: noarch
%description -n %{name}+any_zlib-devel %{_description}
This package contains library source intended for building other packages
which use "any_zlib" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "any_zlib" feature of the "%{crate}" crate.
%files -n %{name}+any_zlib-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+futures-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-devel %{_description}
This package contains library source intended for building other packages
which use "futures" feature of "%{crate}" crate.
%files -n %{name}+futures-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libz-sys-devel
Summary: %{summary}
@ -89,11 +72,11 @@ BuildArch: noarch
%description -n %{name}+libz-sys-devel %{_description}
This package contains library source intended for building other packages
which use "libz-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "libz-sys" feature of the "%{crate}" crate.
%files -n %{name}+libz-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+miniz-sys-devel
Summary: %{summary}
@ -101,11 +84,11 @@ BuildArch: noarch
%description -n %{name}+miniz-sys-devel %{_description}
This package contains library source intended for building other packages
which use "miniz-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "miniz-sys" feature of the "%{crate}" crate.
%files -n %{name}+miniz-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+miniz_oxide-devel
Summary: %{summary}
@ -113,11 +96,11 @@ BuildArch: noarch
%description -n %{name}+miniz_oxide-devel %{_description}
This package contains library source intended for building other packages
which use "miniz_oxide" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "miniz_oxide" feature of the "%{crate}" crate.
%files -n %{name}+miniz_oxide-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rust_backend-devel
Summary: %{summary}
@ -125,35 +108,11 @@ BuildArch: noarch
%description -n %{name}+rust_backend-devel %{_description}
This package contains library source intended for building other packages
which use "rust_backend" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rust_backend" feature of the "%{crate}" crate.
%files -n %{name}+rust_backend-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages
which use "tokio" feature of "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-io-devel %{_description}
This package contains library source intended for building other packages
which use "tokio-io" feature of "%{crate}" crate.
%files -n %{name}+tokio-io-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zlib-devel
Summary: %{summary}
@ -161,11 +120,11 @@ BuildArch: noarch
%description -n %{name}+zlib-devel %{_description}
This package contains library source intended for building other packages
which use "zlib" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "zlib" feature of the "%{crate}" crate.
%files -n %{name}+zlib-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -0,0 +1,7 @@
[DEFAULT]
unwanted-features =
cloudflare-zlib-sys
libz-ng-sys
cloudflare_zlib
zlib-ng
zlib-ng-compat

@ -1 +1 @@
SHA512 (flate2-1.0.22.crate) = c76fa3b097774f1da884b969285bb3aa7fac489446845c93dec1afe6b94bfa11f708e6718d5e4460022b9398a698378a210c3b25e9e676d2bde9d5be1a63261f
SHA512 (flate2-1.0.24.crate) = 8faf97c28dcc4553f4880295677b1269b4acbc6518d006913d32d7e319990c6631e10f1baf7199b96e03f6de95b9e2de04502522bb1eb45bc301a0fbb0bfc0c5

Loading…
Cancel
Save