initial import (#1964694)
parent
5a68ea1429
commit
e1095560a6
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/femme-2.1.1.crate
|
@ -0,0 +1,16 @@
|
|||||||
|
--- femme-2.1.1/Cargo.toml 2020-08-10T13:59:21+00:00
|
||||||
|
+++ femme-2.1.1/Cargo.toml 2021-04-28T23:38:02.172034+00:00
|
||||||
|
@@ -38,13 +38,3 @@
|
||||||
|
version = "1.0.56"
|
||||||
|
[dev-dependencies.kv-log-macro]
|
||||||
|
version = "1.0.5"
|
||||||
|
-[target."cfg(target_arch = \"wasm32\")".dependencies.js-sys]
|
||||||
|
-version = "0.3.25"
|
||||||
|
-
|
||||||
|
-[target."cfg(target_arch = \"wasm32\")".dependencies.wasm-bindgen]
|
||||||
|
-version = "0.2.48"
|
||||||
|
-features = ["serde-serialize"]
|
||||||
|
-
|
||||||
|
-[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
|
||||||
|
-version = "0.3.25"
|
||||||
|
-features = ["console"]
|
@ -0,0 +1,78 @@
|
|||||||
|
# Generated by rust2rpm 17
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate femme
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 2.1.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Pretty-printer and ndjson logger for log crate
|
||||||
|
|
||||||
|
# Upstream license specification: MIT OR Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/femme
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * drop WASM-specific dependencies
|
||||||
|
Patch0: femme-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Not just a pretty (inter)face: pretty-printer and ndjson logger for log crate.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-APACHE LICENSE-MIT
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue May 25 2021 Fabio Valentini <decathorpe@gmail.com> - 2.1.1-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue