import #1967345
parent
b01495c384
commit
631c8aec6c
@ -0,0 +1 @@
|
|||||||
|
/fd-lock-2.0.0.crate
|
@ -0,0 +1,8 @@
|
|||||||
|
--- fd-lock-2.0.0/Cargo.toml 2020-12-21T17:21:13+00:00
|
||||||
|
+++ fd-lock-2.0.0/Cargo.toml 2021-06-02T23:40:14.423526+00:00
|
||||||
|
@@ -26,5 +26,3 @@
|
||||||
|
version = "0.2.58"
|
||||||
|
[dev-dependencies.tempfile]
|
||||||
|
version = "3.0.8"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3.7"
|
@ -0,0 +1,80 @@
|
|||||||
|
# Generated by rust2rpm 17
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate fd-lock
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 2.0.0
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: Advisory cross-platform lock on a file using a file descriptor to it
|
||||||
|
|
||||||
|
# Upstream license specification: MIT OR Apache-2.0
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/fd-lock
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Drop windows dependencies
|
||||||
|
Patch0: fd-lock-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Advisory cross-platform lock on a file using a file descriptor to it.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-APACHE LICENSE-MIT
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Jun 06 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 2.0.0-2
|
||||||
|
- Install license files
|
||||||
|
|
||||||
|
* Wed Jun 02 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 2.0.0-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue