commit
9cbcf296da
@ -0,0 +1,24 @@
|
|||||||
|
--- a/src/main.rs
|
||||||
|
+++ b/src/main.rs
|
||||||
|
@@ -33,21 +33,6 @@ use crate::filter::OwnerFilter;
|
||||||
|
use crate::filter::TimeFilter;
|
||||||
|
use crate::regex_helper::{pattern_has_uppercase_char, pattern_matches_strings_with_leading_dot};
|
||||||
|
|
||||||
|
-// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481
|
||||||
|
-// FIXME: re-enable jemalloc on macOS, see comment in Cargo.toml file for more infos
|
||||||
|
-#[cfg(all(
|
||||||
|
- not(windows),
|
||||||
|
- not(target_os = "android"),
|
||||||
|
- not(target_os = "macos"),
|
||||||
|
- not(target_os = "freebsd"),
|
||||||
|
- not(target_os = "openbsd"),
|
||||||
|
- not(all(target_env = "musl", target_pointer_width = "32")),
|
||||||
|
- not(target_arch = "riscv64"),
|
||||||
|
- feature = "use-jemalloc"
|
||||||
|
-))]
|
||||||
|
-#[global_allocator]
|
||||||
|
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
|
||||||
|
-
|
||||||
|
// vivid --color-mode 8-bit generate molokai
|
||||||
|
const DEFAULT_LS_COLORS: &str = "
|
||||||
|
ow=0:or=0;38;5;16;48;5;203:no=0:ex=1;38;5;203:cd=0;38;5;203;48;5;236:mi=0;38;5;16;48;5;203:*~=0;38;5;243:st=0:pi=0;38;5;16;48;5;81:fi=0:di=0;38;5;81:so=0;38;5;16;48;5;203:bd=0;38;5;81;48;5;236:tw=0:ln=0;38;5;203:*.m=0;38;5;48:*.o=0;38;5;243:*.z=4;38;5;203:*.a=1;38;5;203:*.r=0;38;5;48:*.c=0;38;5;48:*.d=0;38;5;48:*.t=0;38;5;48:*.h=0;38;5;48:*.p=0;38;5;48:*.cc=0;38;5;48:*.ll=0;38;5;48:*.jl=0;38;5;48:*css=0;38;5;48:*.md=0;38;5;185:*.gz=4;38;5;203:*.nb=0;38;5;48:*.mn=0;38;5;48:*.go=0;38;5;48:*.xz=4;38;5;203:*.so=1;38;5;203:*.rb=0;38;5;48:*.pm=0;38;5;48:*.bc=0;38;5;243:*.py=0;38;5;48:*.as=0;38;5;48:*.pl=0;38;5;48:*.rs=0;38;5;48:*.sh=0;38;5;48:*.7z=4;38;5;203:*.ps=0;38;5;186:*.cs=0;38;5;48:*.el=0;38;5;48:*.rm=0;38;5;208:*.hs=0;38;5;48:*.td=0;38;5;48:*.ui=0;38;5;149:*.ex=0;38;5;48:*.js=0;38;5;48:*.cp=0;38;5;48:*.cr=0;38;5;48:*.la=0;38;5;243:*.kt=0;38;5;48:*.ml=0;38;5;48:*.vb=0;38;5;48:*.gv=0;38;5;48:*.lo=0;38;5;243:*.hi=0;38;5;243:*.ts=0;38;5;48:*.ko=1;38;5;203:*.hh=0;38;5;48:*.pp=0;38;5;48:*.di=0;38;5;48:*.bz=4;38;5;203:*.fs=0;38;5;48:*.png=0;38;5;208:*.zsh=0;38;5;48:*.mpg=0;38;5;208:*.pid=0;38;5;243:*.xmp=0;38;5;149:*.iso=4;38;5;203:*.m4v=0;38;5;208:*.dot=0;38;5;48:*.ods=0;38;5;186:*.inc=0;38;5;48:*.sxw=0;38;5;186:*.aif=0;38;5;208:*.git=0;38;5;243:*.gvy=0;38;5;48:*.tbz=4;38;5;203:*.log=0;38;5;243:*.txt=0;38;5;185:*.ico=0;38;5;208:*.csx=0;38;5;48:*.vob=0;38;5;208:*.pgm=0;38;5;208:*.pps=0;38;5;186:*.ics=0;38;5;186:*.img=4;38;5;203:*.fon=0;38;5;208:*.hpp=0;38;5;48:*.bsh=0;38;5;48:*.sql=0;38;5;48:*TODO=1:*.php=0;38;5;48:*.pkg=4;38;5;203:*.ps1=0;38;5;48:*.csv=0;38;5;185:*.ilg=0;38;5;243:*.ini=0;38;5;149:*.pyc=0;38;5;243:*.psd=0;38;5;208:*.htc=0;38;5;48:*.swp=0;38;5;243:*.mli=0;38;5;48:*hgrc=0;38;5;149:*.bst=0;38;5;149:*.ipp=0;38;5;48:*.fsi=0;38;5;48:*.tcl=0;38;5;48:*.exs=0;38;5;48:*.out=0;38;5;243:*.jar=4;38;5;203:*.xls=0;38;5;186:*.ppm=0;38;5;208:*.apk=4;38;5;203:*.aux=0;38;5;243:*.rpm=4;38;5;203:*.dll=1;38;5;203:*.eps=0;38;5;208:*.exe=1;38;5;203:*.doc=0;38;5;186:*.wma=0;38;5;208:*.deb=4;38;5;203:*.pod=0;38;5;48:*.ind=0;38;5;243:*.nix=0;38;5;149:*.lua=0;38;5;48:*.epp=0;38;5;48:*.dpr=0;38;5;48:*.htm=0;38;5;185:*.ogg=0;38;5;208:*.bin=4;38;5;203:*.otf=0;38;5;208:*.yml=0;38;5;149:*.pro=0;38;5;149:*.cxx=0;38;5;48:*.tex=0;38;5;48:*.fnt=0;38;5;208:*.erl=0;38;5;48:*.sty=0;38;5;243:*.bag=4;38;5;203:*.rst=0;38;5;185:*.pdf=0;38;5;186:*.pbm=0;38;5;208:*.xcf=0;38;5;208:*.clj=0;38;5;48:*.gif=0;38;5;208:*.rar=4;38;5;203:*.elm=0;38;5;48:*.bib=0;38;5;149:*.tsx=0;38;5;48:*.dmg=4;38;5;203:*.tmp=0;38;5;243:*.bcf=0;38;5;243:*.mkv=0;38;5;208:*.svg=0;38;5;208:*.cpp=0;38;5;48:*.vim=0;38;5;48:*.bmp=0;38;5;208:*.ltx=0;38;5;48:*.fls=0;38;5;243:*.flv=0;38;5;208:*.wav=0;38;5;208:*.m4a=0;38;5;208:*.mid=0;38;5;208:*.hxx=0;38;5;48:*.pas=0;38;5;48:*.wmv=0;38;5;208:*.tif=0;38;5;208:*.kex=0;38;5;186:*.mp4=0;38;5;208:*.bak=0;38;5;243:*.xlr=0;38;5;186:*.dox=0;38;5;149:*.swf=0;38;5;208:*.tar=4;38;5;203:*.tgz=4;38;5;203:*.cfg=0;38;5;149:*.xml=0;
|
Binary file not shown.
@ -0,0 +1,21 @@
|
|||||||
|
--- fd-find-8.7.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ fd-find-8.7.1/Cargo.toml 2023-10-27T04:29:57.025911+00:00
|
||||||
|
@@ -125,17 +125,11 @@
|
||||||
|
version = "0.9"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-base = ["use-jemalloc"]
|
||||||
|
+base = []
|
||||||
|
completions = ["clap_complete"]
|
||||||
|
default = [
|
||||||
|
- "use-jemalloc",
|
||||||
|
"completions",
|
||||||
|
]
|
||||||
|
-use-jemalloc = ["jemallocator"]
|
||||||
|
-
|
||||||
|
-[target."cfg(all(not(windows), not(target_os = \"android\"), not(target_os = \"macos\"), not(target_os = \"freebsd\"), not(target_os = \"openbsd\"), not(all(target_env = \"musl\", target_pointer_width = \"32\")), not(target_arch = \"riscv64\")))".dependencies.jemallocator]
|
||||||
|
-version = "0.5.4"
|
||||||
|
-optional = true
|
||||||
|
|
||||||
|
[target."cfg(all(unix, not(target_os = \"redox\")))".dependencies.libc]
|
||||||
|
version = "0.2"
|
@ -0,0 +1,241 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
|
||||||
|
%global crate fd-find
|
||||||
|
|
||||||
|
Name: rust-fd-find
|
||||||
|
Version: 8.7.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Fd is a simple, fast and user-friendly alternative to find
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/fd-find
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop jemallocator dependency
|
||||||
|
Patch: fd-find-fix-metadata.diff
|
||||||
|
# * drop jemallocator from code
|
||||||
|
Patch: fd-find-8.7.1-remove_usage_of_jemallocator.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 23
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Fd is a simple, fast and user-friendly alternative to find.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package -n %{crate}
|
||||||
|
Summary: %{summary}
|
||||||
|
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
|
||||||
|
# Apache-2.0 OR MIT
|
||||||
|
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
||||||
|
# MIT
|
||||||
|
# MIT OR Apache-2.0
|
||||||
|
# Unlicense OR MIT
|
||||||
|
License: MIT AND Unicode-DFS-2016
|
||||||
|
# LICENSE.dependencies contains a full license breakdown
|
||||||
|
|
||||||
|
%description -n %{crate} %{_description}
|
||||||
|
|
||||||
|
%files -n %{crate}
|
||||||
|
%license LICENSE-APACHE
|
||||||
|
%license LICENSE-MIT
|
||||||
|
%license LICENSE.dependencies
|
||||||
|
%doc CHANGELOG.md
|
||||||
|
%doc CONTRIBUTING.md
|
||||||
|
%doc README.md
|
||||||
|
%{_bindir}/fd
|
||||||
|
%{_mandir}/man1/fd.1*
|
||||||
|
%{bash_completions_dir}/fd
|
||||||
|
%{fish_completions_dir}/fd.fish
|
||||||
|
%{zsh_completions_dir}/_fd
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
%{cargo_license_summary}
|
||||||
|
%{cargo_license} > LICENSE.dependencies
|
||||||
|
# generate shell completions
|
||||||
|
./target/release/fd --gen-completions bash > fd.bash
|
||||||
|
./target/release/fd --gen-completions fish > fd.fish
|
||||||
|
./target/release/fd --gen-completions zsh > fd.zsh
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
# install manpage
|
||||||
|
install -Dpm 644 doc/fd.1 -t %{buildroot}/%{_mandir}/man1/
|
||||||
|
# install shell completions
|
||||||
|
install -Dpm 0644 fd.bash %{buildroot}/%{bash_completions_dir}/fd
|
||||||
|
install -Dpm 0644 fd.fish %{buildroot}/%{fish_completions_dir}/fd.fish
|
||||||
|
install -Dpm 0644 fd.zsh %{buildroot}/%{zsh_completions_dir}/_fd
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 8.7.1-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Sat Oct 28 2023 Michel Lind <salimma@fedoraproject.org> - 8.7.1-1
|
||||||
|
- Update to 8.7.1
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 8.7.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 19 2023 Fabio Valentini <decathorpe@gmail.com> - 8.7.0-2
|
||||||
|
- Remove stabilized but previously unstable "clap/unstable-grouped" feature
|
||||||
|
|
||||||
|
* Fri Mar 03 2023 Fabio Valentini <decathorpe@gmail.com> - 8.7.0-1
|
||||||
|
- Update to version 8.7.0; Fixes RHBZ#2027038
|
||||||
|
|
||||||
|
* Sat Feb 04 2023 Fabio Valentini <decathorpe@gmail.com> - 8.2.1-11
|
||||||
|
- Rebuild for fixed frame pointer compiler flags in Rust RPM macros.
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 8.2.1-10
|
||||||
|
- Bump lscolors from 0.10 to 0.13.
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 8.2.1-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fabio Valentini <decathorpe@gmail.com> - 8.2.1-8
|
||||||
|
- Bump lscolors from 0.7 to 0.10.
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 8.2.1-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Feb 15 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 8.2.1-6
|
||||||
|
- Rebuild with package notes
|
||||||
|
|
||||||
|
* Tue Jan 25 2022 Fabio Valentini <decathorpe@gmail.com> - 8.2.1-5
|
||||||
|
- Rebuild with thread_local 1.1.4 for RUSTSEC-2022-0006.
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 8.2.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 8.2.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 8.2.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 12 2021 Fabio Valentini <decathorpe@gmail.com> - 8.2.1-1
|
||||||
|
- Update to version 8.2.1.
|
||||||
|
- Fixes RHBZ#1904838
|
||||||
|
|
||||||
|
* Mon Dec 28 13:29:47 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.1.1-4
|
||||||
|
- Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 16 15:01:25 GMT 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.1.1-3
|
||||||
|
- Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 8.1.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 25 17:00:41 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.1.1-1
|
||||||
|
- Update to 8.1.1
|
||||||
|
|
||||||
|
* Fri May 22 12:25:14 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.1.0-1
|
||||||
|
- Update to 8.1.0
|
||||||
|
|
||||||
|
* Thu Apr 16 11:42:05 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.0.0-1
|
||||||
|
- Update to 8.0.0
|
||||||
|
|
||||||
|
* Sun Mar 22 17:19:42 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 7.5.0-1
|
||||||
|
- Update to 7.5.0
|
||||||
|
|
||||||
|
* Thu Mar 19 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 7.4.0-3
|
||||||
|
- Correct license
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.4.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Dec 07 12:09:52 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.4.0-1
|
||||||
|
- Update to 7.4.0
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.3.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 22 19:19:49 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.3.0-3
|
||||||
|
- Regenerate
|
||||||
|
|
||||||
|
* Sun Jul 21 18:29:00 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.3.0-2
|
||||||
|
- Correct fish completions directory
|
||||||
|
|
||||||
|
* Sat Apr 27 18:51:07 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.3.0-1
|
||||||
|
- Update to 7.3.0
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Oct 30 2018 Josh Stone <jistone@redhat.com> - 7.2.0-1
|
||||||
|
- Update to 7.2.0
|
||||||
|
|
||||||
|
* Fri Sep 07 2018 Josh Stone <jistone@redhat.com> - 7.1.0-1
|
||||||
|
- Update to 7.1.0
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 16 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.0.0-2
|
||||||
|
- Bump regex to 1
|
||||||
|
|
||||||
|
* Mon Mar 26 2018 Josh Stone <jistone@redhat.com> - 7.0.0-1
|
||||||
|
- Update to 7.0.0
|
||||||
|
|
||||||
|
* Wed Mar 14 2018 Josh Stone <jistone@redhat.com> - 6.3.0-2
|
||||||
|
- Bump regex-syntax to 0.5
|
||||||
|
|
||||||
|
* Mon Feb 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.3.0-1
|
||||||
|
- Update to 6.3.0
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.2.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 17 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.2.0-4
|
||||||
|
- Rebuild for clap 2.29.2 (zsh completion fixes)
|
||||||
|
|
||||||
|
* Wed Jan 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.2.0-3
|
||||||
|
- Rebuild for clap 2.29.1
|
||||||
|
|
||||||
|
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.2.0-2
|
||||||
|
- Rebuild for rust-packaging v5
|
||||||
|
|
||||||
|
* Thu Jan 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.2.0-1
|
||||||
|
- Update to 6.2.0
|
||||||
|
|
||||||
|
* Wed Dec 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.1.0-1
|
||||||
|
- Update to 6.1.0
|
||||||
|
|
||||||
|
* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.0.0-5
|
||||||
|
- Bump lazy_static to 1
|
||||||
|
|
||||||
|
* Tue Nov 28 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.0.0-4
|
||||||
|
- Rebuild for clap 2.28.0
|
||||||
|
|
||||||
|
* Thu Nov 23 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.0.0-3
|
||||||
|
- Fix bash completion
|
||||||
|
|
||||||
|
* Thu Nov 23 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.0.0-2
|
||||||
|
- Package completions
|
||||||
|
|
||||||
|
* Mon Nov 20 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.0.0-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue