Update to 0.3.0; Fixes: RHBZ#1983809

epel9
Davide Cavalca 4 years ago
parent d496e27507
commit c56fe1bc72

1
.gitignore vendored

@ -1 +1,2 @@
/fb_procfs-0.2.0.crate
/fb_procfs-0.3.0.crate

@ -1,11 +0,0 @@
--- fb_procfs-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ fb_procfs-0.2.0/Cargo.toml 2021-06-15T23:53:16.139460+00:00
@@ -29,7 +29,7 @@
version = "0.1.20"
[dependencies.serde]
-version = "=1.0.118"
+version = "1.0.126"
features = ["derive", "rc"]
[dependencies.thiserror]

@ -1,12 +0,0 @@
diff -Naur a/src/test.rs b/src/test.rs
--- a/src/test.rs 1969-12-31 16:00:00.000000000 -0800
+++ b/src/test.rs 2021-06-16 08:12:25.653600395 -0700
@@ -92,7 +92,7 @@
&self,
interface: &str,
p: P,
- content: usize,
+ content: u64,
) {
let interface_dir = self.path().join(interface);
if !interface_dir.exists() {

@ -1,11 +1,11 @@
# Generated by rust2rpm 16
# Generated by rust2rpm 18
%bcond_without check
%global debug_package %{nil}
%global crate fb_procfs
Name: rust-%{crate}
Version: 0.2.0
Version: 0.3.0
Release: %autorelease
Summary: Crate for reading procfs
@ -13,10 +13,6 @@ Summary: Crate for reading procfs
License: ASL 2.0
URL: https://crates.io/crates/fb_procfs
Source: %{crates_source}
# Bump serde to 1.0.126
Patch0: fb_procfs-fix-metadata.diff
# Fix the tests on 32bit arches
Patch1: fb_procfs-fix-tests-32bit.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}

@ -1 +1 @@
SHA512 (fb_procfs-0.2.0.crate) = 62107ea5907c885555d38bb1f7ab23b4e3f95420b90903601c29d7f15d41bd6c96a69cb5b35e0779fbc7a6a7b267e46392e3abf5d8f2d826d2ecb86471ef76a9
SHA512 (fb_procfs-0.3.0.crate) = f1e26468c42454c1abeb91bc97f431fe06432ea7e6647a6f0b639143aab70789106d715d13daff7a971141215bdf0a3f3ef7ac5694a8f7d82999d3ff72cee616

Loading…
Cancel
Save