parent
d45e4ce97f
commit
bbcd16aafa
@ -1,2 +1,3 @@
|
|||||||
/fb_procfs-0.4.1.crate
|
/fb_procfs-0.4.1.crate
|
||||||
/fb_procfs-0.5.0.crate
|
/fb_procfs-0.5.0.crate
|
||||||
|
/fb_procfs-0.6.3.crate
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff '--color=auto' -ruN fb_procfs-0.5.0/src/lib.rs fb_procfs-0.5.0-fix-32bit/src/lib.rs
|
|
||||||
--- fb_procfs-0.5.0/src/lib.rs 1973-11-29 13:33:09.000000000 -0800
|
|
||||||
+++ fb_procfs-0.5.0-fix-32bit/src/lib.rs 2022-02-17 10:01:07.365184992 -0800
|
|
||||||
@@ -385,7 +385,7 @@
|
|
||||||
if let Ok(stat) = sys::statvfs::statvfs(Path::new(&mount_point)) {
|
|
||||||
let disk_usage = ((stat.blocks() - stat.blocks_available()) as f32 * 100.0)
|
|
||||||
/ stat.blocks() as f32;
|
|
||||||
- let partition_size = stat.blocks() * stat.block_size() as u64;
|
|
||||||
+ let partition_size = stat.blocks() as u64 * stat.block_size() as u64;
|
|
||||||
return Some((disk_usage, partition_size));
|
|
||||||
}
|
|
||||||
}
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- fb_procfs-0.6.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ fb_procfs-0.6.3/Cargo.toml 2023-01-19T03:29:51.618270+00:00
|
||||||
|
@@ -30,7 +30,7 @@
|
||||||
|
version = "0.2.135"
|
||||||
|
|
||||||
|
[dependencies.nix]
|
||||||
|
-version = "0.25"
|
||||||
|
+version = "0.26"
|
||||||
|
|
||||||
|
[dependencies.openat]
|
||||||
|
version = "0.1.21"
|
@ -1 +1 @@
|
|||||||
SHA512 (fb_procfs-0.5.0.crate) = 1b4ddfb10bf53a602172d2e8e0a59bbb38279aa182eb4de47d647f4247250aa7766ea282779ee6ce1693167c7c5e3337e1234a1bc846e0b9c094d7577433e53a
|
SHA512 (fb_procfs-0.6.3.crate) = ff57555ef597b8b7d2f0c5da03586292f0ea1cf0b73e78500a35a242a68ea7ce1fe2dead45ea13d03f00ff3992f3deb6e0cb32cb410977da762b2206a1700f67
|
||||||
|
Loading…
Reference in new issue