Initial package (#1972781)
parent
67de29dfe5
commit
7cff7f6578
@ -0,0 +1 @@
|
||||
/fb_procfs-0.2.0.crate
|
@ -0,0 +1,11 @@
|
||||
--- fb_procfs-0.2.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ fb_procfs-0.2.0/Cargo.toml 2021-06-15T23:53:16.139460+00:00
|
||||
@@ -29,7 +29,7 @@
|
||||
version = "0.1.20"
|
||||
|
||||
[dependencies.serde]
|
||||
-version = "=1.0.118"
|
||||
+version = "1.0.126"
|
||||
features = ["derive", "rc"]
|
||||
|
||||
[dependencies.thiserror]
|
@ -0,0 +1,12 @@
|
||||
diff -Naur a/src/test.rs b/src/test.rs
|
||||
--- a/src/test.rs 1969-12-31 16:00:00.000000000 -0800
|
||||
+++ b/src/test.rs 2021-06-16 08:12:25.653600395 -0700
|
||||
@@ -92,7 +92,7 @@
|
||||
&self,
|
||||
interface: &str,
|
||||
p: P,
|
||||
- content: usize,
|
||||
+ content: u64,
|
||||
) {
|
||||
let interface_dir = self.path().join(interface);
|
||||
if !interface_dir.exists() {
|
@ -0,0 +1,79 @@
|
||||
# Generated by rust2rpm 16
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate fb_procfs
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Crate for reading procfs
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/fb_procfs
|
||||
Source: %{crates_source}
|
||||
# Bump serde to 1.0.126
|
||||
Patch0: fb_procfs-fix-metadata.diff
|
||||
# Fix the tests on 32bit arches
|
||||
Patch1: fb_procfs-fix-tests-32bit.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Crate for reading procfs.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jun 15 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.2.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue