commit
d36f5e7605
Binary file not shown.
@ -0,0 +1,21 @@
|
|||||||
|
--- fastrand-2.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ fastrand-2.0.1/Cargo.toml 2023-09-26T16:53:36.810445+00:00
|
||||||
|
@@ -50,18 +50,6 @@
|
||||||
|
default = ["std"]
|
||||||
|
js = [
|
||||||
|
"std",
|
||||||
|
- "getrandom",
|
||||||
|
]
|
||||||
|
std = ["alloc"]
|
||||||
|
|
||||||
|
-[target."cfg(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\"))".dependencies.getrandom]
|
||||||
|
-version = "0.2"
|
||||||
|
-features = ["js"]
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[target."cfg(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\"))".dev-dependencies.getrandom]
|
||||||
|
-version = "0.2"
|
||||||
|
-features = ["js"]
|
||||||
|
-
|
||||||
|
-[target."cfg(all(any(target_arch = \"wasm32\", target_arch = \"wasm64\"), target_os = \"unknown\"))".dev-dependencies.wasm-bindgen-test]
|
||||||
|
-version = "0.3"
|
@ -0,0 +1,11 @@
|
|||||||
|
--- fastrand-2.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ fastrand-2.0.1/Cargo.toml 2023-09-26T16:53:47.491498+00:00
|
||||||
|
@@ -48,8 +48,5 @@
|
||||||
|
[features]
|
||||||
|
alloc = []
|
||||||
|
default = ["std"]
|
||||||
|
-js = [
|
||||||
|
- "std",
|
||||||
|
-]
|
||||||
|
std = ["alloc"]
|
||||||
|
|
@ -0,0 +1,160 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
# * missing dev-dependency: wyhash ^0.5
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate fastrand
|
||||||
|
|
||||||
|
Name: rust-fastrand
|
||||||
|
Version: 2.0.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Simple and fast random number generator
|
||||||
|
|
||||||
|
License: Apache-2.0 OR MIT
|
||||||
|
URL: https://crates.io/crates/fastrand
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: fastrand-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * remove WASM-specific "js" feature
|
||||||
|
Patch: fastrand-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A simple and fast random number generator.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "alloc" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Nov 20 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.0.1-1
|
||||||
|
- Rebuilt for MSVSphere 9.2
|
||||||
|
|
||||||
|
* Tue Sep 26 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.1-1
|
||||||
|
- Update to version 2.0.1; Fixes RHBZ#2240667
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 05 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.0-1
|
||||||
|
- Update to version 2.0.0; Fixes RHBZ#2213682
|
||||||
|
|
||||||
|
* Sun Feb 19 2023 Fabio Valentini <decathorpe@gmail.com> - 1.9.0-1
|
||||||
|
- Update to version 1.9.0; Fixes RHBZ#2169601
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 27 2022 Fabio Valentini <decathorpe@gmail.com> - 1.8.0-1
|
||||||
|
- Update to version 1.8.0; Fixes RHBZ#2110109
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 26 2022 Fabio Valentini <decathorpe@gmail.com> - 1.7.0-1
|
||||||
|
- Update to version 1.7.0; Fixes RHBZ#2043827
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 21 2021 Fabio Valentini <decathorpe@gmail.com> - 1.6.0-1
|
||||||
|
- Update to version 1.6.0; Fixes RHBZ#1983746
|
||||||
|
|
||||||
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-2
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 28 2021 Fabio Valentini <decathorpe@gmail.com> - 1.4.1-1
|
||||||
|
- Update to version 1.4.1.
|
||||||
|
- Fixes RHBZ#1953168
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 06 17:11:04 CET 2021 Fabio Valentini <decathorpe@gmail.com> - 1.4.0-1
|
||||||
|
- Update to version 1.4.0.
|
||||||
|
- Fixes RHBZ#1913388
|
||||||
|
|
||||||
|
* Mon Aug 03 02:00:40 +04 2020 Marc-André Lureau <marcandre.lureau@redhat.com> - 1.3.4-1
|
||||||
|
- Initial package, rhbz#1862945
|
||||||
|
|
Loading…
Reference in new issue