Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>epel9 imports/e9/rust-fancy-regex0.7-0.7.1-1.el9
parent
f3182f1dd2
commit
a107a53402
@ -0,0 +1 @@
|
|||||||
|
/fancy-regex-0.7.1.crate
|
@ -0,0 +1,18 @@
|
|||||||
|
--- fancy-regex-0.7.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ fancy-regex-0.7.1/Cargo.toml 2023-01-22T19:35:07.042003+00:00
|
||||||
|
@@ -30,14 +30,12 @@
|
||||||
|
|
||||||
|
[dependencies.regex]
|
||||||
|
version = "1.2"
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "= 0.3.4"
|
||||||
|
|
||||||
|
[dev-dependencies.matches]
|
||||||
|
version = "0.1.8"
|
||||||
|
|
||||||
|
[dev-dependencies.quickcheck]
|
||||||
|
-version = "= 1.0.1"
|
||||||
|
+version = "1.0.1"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
track_caller = []
|
@ -0,0 +1,89 @@
|
|||||||
|
# Generated by rust2rpm 23
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate fancy-regex
|
||||||
|
|
||||||
|
Name: rust-fancy-regex0.7
|
||||||
|
Version: 0.7.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Implementation of regexes, supporting a relatively rich set of features
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/fancy-regex
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||||
|
# * relax quickcheck dev-dependency from =1.0.1 to ^1.0.1
|
||||||
|
Patch: fancy-regex-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Implementation of regexes, supporting a relatively rich set of features,
|
||||||
|
including backreferences and look-around.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/AUTHORS
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||||
|
%doc %{crate_instdir}/PERFORMANCE.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+track_caller-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+track_caller-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "track_caller" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+track_caller-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue