import rust-fancy-regex0.11-0.11.0-2.el10

i10ce changed/i10ce/rust-fancy-regex0.11-0.11.0-2.el10
MSVSphere Packaging Team 2 months ago
commit a7754de1cb
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/fancy-regex-0.11.0.crate

@ -0,0 +1 @@
9226db0b89f92c37d0fcb98da7b30ef5621b68a4 SOURCES/fancy-regex-0.11.0.crate

@ -0,0 +1,3 @@
# rust-fancy-regex0.11
The rust-fancy-regex0.11 package

@ -0,0 +1,12 @@
--- fancy-regex-0.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ fancy-regex-0.11.0/Cargo.toml 2024-03-20T22:52:05.523561+00:00
@@ -40,9 +40,6 @@
features = ["std"]
default-features = false
-[dev-dependencies.criterion]
-version = "0.3.0"
-
[dev-dependencies.matches]
version = "0.1.8"

@ -0,0 +1,2 @@
[package]
summary = "An implementation of regexes, supporting a relatively rich set of features"

@ -0,0 +1,178 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 2;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate fancy-regex
Name: rust-fancy-regex0.11
Version: 0.11.0
Release: %autorelease
Summary: An implementation of regexes, supporting a relatively rich set of features
License: MIT
URL: https://crates.io/crates/fancy-regex
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
Patch: fancy-regex-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
An implementation of regexes, supporting a relatively rich set of
features, including backreferences and look-around.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/AUTHORS
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/PERFORMANCE.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-devel %{_description}
This package contains library source intended for building other packages which
use the "perf" feature of the "%{crate}" crate.
%files -n %{name}+perf-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-cache-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-cache-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-cache" feature of the "%{crate}" crate.
%files -n %{name}+perf-cache-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-dfa-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-dfa-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-dfa" feature of the "%{crate}" crate.
%files -n %{name}+perf-dfa-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-inline-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-inline-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-inline" feature of the "%{crate}" crate.
%files -n %{name}+perf-inline-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+perf-literal-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+perf-literal-devel %{_description}
This package contains library source intended for building other packages which
use the "perf-literal" feature of the "%{crate}" crate.
%files -n %{name}+perf-literal-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+track_caller-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+track_caller-devel %{_description}
This package contains library source intended for building other packages which
use the "track_caller" feature of the "%{crate}" crate.
%files -n %{name}+track_caller-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode" feature of the "%{crate}" crate.
%files -n %{name}+unicode-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.11.0-2
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Wed Mar 20 2024 Michel Lind <salimma@fedoraproject.org> - 0.11.0-1
- Initial package (rhbz#2270553)
## END: Generated by rpmautospec
Loading…
Cancel
Save