Update to version 0.5.1; Fixes RHBZ#2324311

Signed-off-by: Benjamin A. Beasley <code@musicinmybrain.net>
epel10 imports/epel10/rust-fallible_collections-0.5.1-1.el10
Benjamin A. Beasley 2 months ago
parent e29c51bbe9
commit d2e428897e

1
.gitignore vendored

@ -5,3 +5,4 @@
/fallible_collections-0.4.7.crate /fallible_collections-0.4.7.crate
/fallible_collections-0.4.8.crate /fallible_collections-0.4.8.crate
/fallible_collections-0.4.9.crate /fallible_collections-0.4.9.crate
/fallible_collections-0.5.1.crate

@ -1,11 +0,0 @@
--- fallible_collections-0.4.9/Cargo.toml 1970-01-01T00:00:01+00:00
+++ fallible_collections-0.4.9/Cargo.toml 2024-09-15T19:04:19.858635+00:00
@@ -24,7 +24,7 @@
repository = "https://github.com/vcombey/fallible_collections.git"
[dependencies.hashbrown]
-version = "0.13"
+version = "0.14"
optional = true
[features]

@ -5,18 +5,13 @@
%global crate fallible_collections %global crate fallible_collections
Name: rust-fallible_collections Name: rust-fallible_collections
Version: 0.4.9 Version: 0.5.1
Release: %autorelease Release: %autorelease
Summary: Which adds fallible allocation api to std collections Summary: Which adds fallible allocation api to std collections
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/fallible_collections URL: https://crates.io/crates/fallible_collections
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * use hashbrown 0.14 instead of 0.13
# (https://github.com/vcombey/fallible_collections/pull/46)
Patch: fallible_collections-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 24
@ -52,18 +47,6 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hashbrown-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hashbrown-devel %{_description}
This package contains library source intended for building other packages which
use the "hashbrown" feature of the "%{crate}" crate.
%files -n %{name}+hashbrown-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hashmap-devel %package -n %{name}+hashmap-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -1,2 +1 @@
SHA512 (fallible_collections-0.4.8.crate) = 66a997b66b2ebf12c2ca308aca386bd86974c2d9b79dff135b4507ee9f7f00021c7f9f1bbb83dc74b01a732182cce7f5b04864c019022f7dbc9492b2bdeac0cd SHA512 (fallible_collections-0.5.1.crate) = 43425e45cdf071f8bad5f7e9d8e1cc30f102b9147161b9fb2356ce025e5d3e13705494d7dc0681276e487ea1866437fa33c2ec0a87bf35dffca6b6be99023906
SHA512 (fallible_collections-0.4.9.crate) = 0b669e8cd7f3335e793b3c420ce1629ace341654d4c2d88a7c665bb24ca747236b85f999d08cd1fe9f46288ce588890d9d7b5d5fc3eb7fbbc0f2cea9822b8682

Loading…
Cancel
Save