parent
6049639a58
commit
1642438318
@ -0,0 +1 @@
|
||||
/faccess-0.2.3.crate
|
@ -0,0 +1,12 @@
|
||||
--- faccess-0.2.3/Cargo.toml 2020-04-01T18:46:18+00:00
|
||||
+++ faccess-0.2.3/Cargo.toml 2021-12-02T14:17:39.662742+00:00
|
||||
@@ -27,6 +27,6 @@
|
||||
version = "1.2.1"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "~0.2.68"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.8"
|
||||
-features = ["accctrl", "aclapi", "handleapi", "impl-default", "minwindef", "processthreadsapi", "securitybaseapi", "winbase", "winerror", "winnt"]
|
||||
+#[target."cfg(windows)".dependencies.winapi]
|
||||
+#version = "0.3.8"
|
||||
+#features = ["accctrl", "aclapi", "handleapi", "impl-default", "minwindef", "processthreadsapi", "securitybaseapi", "winbase", "winerror", "winnt"]
|
@ -0,0 +1,82 @@
|
||||
# Generated by rust2rpm 20
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate faccess
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.3
|
||||
Release: 2%{?dist}
|
||||
Summary: Simple file accessibility checks
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/faccess
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
Patch0: faccess-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Simple file accessibility checks.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE.txt
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%license LICENSE.txt
|
||||
%doc README.md
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%ifnarch %{ix86} x86_64
|
||||
sed -i 's/const i8/const u8/' src/lib.rs
|
||||
%endif
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Dec 02 2021 Lokesh Mandvekar <lsm5@fedoraproject.org> - 0.2.3-2
|
||||
- install license and doc for all subpackages
|
||||
|
||||
* Wed Dec 01 2021 Lokesh Mandvekar <lsm5@fedoraproject.org> - 0.2.3-1
|
||||
- Resolves: #2028271 - initial build
|
Loading…
Reference in new issue