parent
0eb89129ad
commit
e5c2a400e9
@ -0,0 +1 @@
|
||||
/eyre-0.6.8.crate
|
@ -0,0 +1,14 @@
|
||||
--- eyre-0.6.8/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ eyre-0.6.8/Cargo.toml 2022-04-05T02:48:25.755837+00:00
|
||||
@@ -80,11 +80,6 @@
|
||||
version = "0.3"
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.pyo3]
|
||||
-version = "0.13"
|
||||
-features = ["auto-initialize"]
|
||||
-default-features = false
|
||||
-
|
||||
[dev-dependencies.rustversion]
|
||||
version = "1.0"
|
||||
|
@ -0,0 +1,112 @@
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate eyre
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.6.8
|
||||
Release: %autorelease
|
||||
Summary: Flexible concrete Error Reporting type built on std::error::Error with customizable Reports
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/eyre
|
||||
Source: %{crates_source}
|
||||
# Drop optional pyo3/auto-initialize dependency, not available yet
|
||||
Patch0: eyre-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Flexible concrete Error Reporting type built on std::error::Error with
|
||||
customizable Reports.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+auto-install-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+auto-install-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "auto-install" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+auto-install-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pyo3-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pyo3-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pyo3" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pyo3-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+track-caller-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+track-caller-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "track-caller" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+track-caller-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue