Revert "Unused dependency"
This reverts commit 0a67a1a664
.
Signed-off-by: Fedora Release Engineering <releng@fedoraproject.org>
epel10
imports/epel10/rust-etcetera-0.8.0-8.el10
parent
0a67a1a664
commit
d6f9e88035
@ -0,0 +1 @@
|
|||||||
|
/etcetera-0.8.0.crate
|
@ -1 +0,0 @@
|
|||||||
Unused dependency
|
|
@ -0,0 +1,12 @@
|
|||||||
|
--- etcetera-0.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ etcetera-0.8.0/Cargo.toml 2023-10-03T15:58:56.954755+00:00
|
||||||
|
@@ -34,9 +34,3 @@
|
||||||
|
[dependencies.home]
|
||||||
|
version = "0.5"
|
||||||
|
|
||||||
|
-[target."cfg(windows)".dependencies.windows-sys]
|
||||||
|
-version = "0.48"
|
||||||
|
-features = [
|
||||||
|
- "Win32_Foundation",
|
||||||
|
- "Win32_UI_Shell",
|
||||||
|
-]
|
@ -0,0 +1,72 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate etcetera
|
||||||
|
|
||||||
|
Name: rust-etcetera
|
||||||
|
Version: 0.8.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Unopinionated library for obtaining configuration, data, cache, & other directories
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/etcetera
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: etcetera-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
An unopinionated library for obtaining configuration, data, cache, &
|
||||||
|
other directories.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
Loading…
Reference in new issue