parent
e5de27787d
commit
0a67a1a664
@ -1 +0,0 @@
|
|||||||
/etcetera-0.8.0.crate
|
|
@ -0,0 +1 @@
|
|||||||
|
Unused dependency
|
@ -1,12 +0,0 @@
|
|||||||
--- etcetera-0.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
||||||
+++ etcetera-0.8.0/Cargo.toml 2023-10-03T15:58:56.954755+00:00
|
|
||||||
@@ -34,9 +34,3 @@
|
|
||||||
[dependencies.home]
|
|
||||||
version = "0.5"
|
|
||||||
|
|
||||||
-[target."cfg(windows)".dependencies.windows-sys]
|
|
||||||
-version = "0.48"
|
|
||||||
-features = [
|
|
||||||
- "Win32_Foundation",
|
|
||||||
- "Win32_UI_Shell",
|
|
||||||
-]
|
|
@ -1,72 +0,0 @@
|
|||||||
# Generated by rust2rpm 24
|
|
||||||
%bcond_without check
|
|
||||||
%global debug_package %{nil}
|
|
||||||
|
|
||||||
%global crate etcetera
|
|
||||||
|
|
||||||
Name: rust-etcetera
|
|
||||||
Version: 0.8.0
|
|
||||||
Release: %autorelease
|
|
||||||
Summary: Unopinionated library for obtaining configuration, data, cache, & other directories
|
|
||||||
|
|
||||||
License: MIT OR Apache-2.0
|
|
||||||
URL: https://crates.io/crates/etcetera
|
|
||||||
Source: %{crates_source}
|
|
||||||
# Automatically generated patch to strip foreign dependencies
|
|
||||||
Patch: etcetera-fix-metadata-auto.diff
|
|
||||||
|
|
||||||
BuildRequires: rust-packaging >= 21
|
|
||||||
|
|
||||||
%global _description %{expand:
|
|
||||||
An unopinionated library for obtaining configuration, data, cache, &
|
|
||||||
other directories.}
|
|
||||||
|
|
||||||
%description %{_description}
|
|
||||||
|
|
||||||
%package devel
|
|
||||||
Summary: %{summary}
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
%description devel %{_description}
|
|
||||||
|
|
||||||
This package contains library source intended for building other packages which
|
|
||||||
use the "%{crate}" crate.
|
|
||||||
|
|
||||||
%files devel
|
|
||||||
%license %{crate_instdir}/LICENSE-APACHE
|
|
||||||
%license %{crate_instdir}/LICENSE-MIT
|
|
||||||
%doc %{crate_instdir}/README.md
|
|
||||||
%{crate_instdir}/
|
|
||||||
|
|
||||||
%package -n %{name}+default-devel
|
|
||||||
Summary: %{summary}
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
%description -n %{name}+default-devel %{_description}
|
|
||||||
|
|
||||||
This package contains library source intended for building other packages which
|
|
||||||
use the "default" feature of the "%{crate}" crate.
|
|
||||||
|
|
||||||
%files -n %{name}+default-devel
|
|
||||||
%ghost %{crate_instdir}/Cargo.toml
|
|
||||||
|
|
||||||
%prep
|
|
||||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
||||||
%cargo_prep
|
|
||||||
|
|
||||||
%generate_buildrequires
|
|
||||||
%cargo_generate_buildrequires
|
|
||||||
|
|
||||||
%build
|
|
||||||
%cargo_build
|
|
||||||
|
|
||||||
%install
|
|
||||||
%cargo_install
|
|
||||||
|
|
||||||
%if %{with check}
|
|
||||||
%check
|
|
||||||
%cargo_test
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
%autochangelog
|
|
Loading…
Reference in new issue