parent
b9bb0396f5
commit
a3146eec78
@ -0,0 +1,26 @@
|
||||
From f5417d2eb4f0f1398d61c9ecef948c37a073e563 Mon Sep 17 00:00:00 2001
|
||||
From: Sergio Benitez <sb@sergio.bz>
|
||||
Date: Thu, 23 May 2019 21:21:52 -0700
|
||||
Subject: [PATCH] Update version_check to 0.9.
|
||||
|
||||
---
|
||||
build.rs | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/build.rs b/build.rs
|
||||
index 2150a3d..e306f08 100644
|
||||
--- a/build.rs
|
||||
+++ b/build.rs
|
||||
@@ -5,8 +5,7 @@ use version_check::is_min_version;
|
||||
fn main() {
|
||||
// Switch on for versions that have Error::source
|
||||
// As introduced by https://github.com/rust-lang/rust/pull/53533
|
||||
- if is_min_version("1.30").map(|(is_high_enough, _actual_version)| is_high_enough).unwrap_or(false)
|
||||
- {
|
||||
+ if is_min_version("1.30").unwrap_or(false) {
|
||||
println!("cargo:rustc-cfg=has_error_source");
|
||||
}
|
||||
}
|
||||
--
|
||||
2.24.0
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- error-chain-0.12.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ error-chain-0.12.1/Cargo.toml 2019-11-20T11:09:51.791818+00:00
|
||||
@@ -25,7 +25,7 @@
|
||||
version = "0.3.3"
|
||||
optional = true
|
||||
[build-dependencies.version_check]
|
||||
-version = "0.1.5"
|
||||
+version = "0.9"
|
||||
|
||||
[features]
|
||||
default = ["backtrace", "example_generated"]
|
Loading…
Reference in new issue