Update to 0.12.2

epel9
Josh Stone 5 years ago
parent 5876ba70c2
commit 7975e370cb

1
.gitignore vendored

@ -1,3 +1,4 @@
/error-chain-0.11.0.crate /error-chain-0.11.0.crate
/error-chain-0.12.0.crate /error-chain-0.12.0.crate
/error-chain-0.12.1.crate /error-chain-0.12.1.crate
/error-chain-0.12.2.crate

@ -1,26 +0,0 @@
From f5417d2eb4f0f1398d61c9ecef948c37a073e563 Mon Sep 17 00:00:00 2001
From: Sergio Benitez <sb@sergio.bz>
Date: Thu, 23 May 2019 21:21:52 -0700
Subject: [PATCH] Update version_check to 0.9.
---
build.rs | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/build.rs b/build.rs
index 2150a3d..e306f08 100644
--- a/build.rs
+++ b/build.rs
@@ -5,8 +5,7 @@ use version_check::is_min_version;
fn main() {
// Switch on for versions that have Error::source
// As introduced by https://github.com/rust-lang/rust/pull/53533
- if is_min_version("1.30").map(|(is_high_enough, _actual_version)| is_high_enough).unwrap_or(false)
- {
+ if is_min_version("1.30").unwrap_or(false) {
println!("cargo:rustc-cfg=has_error_source");
}
}
--
2.24.0

@ -1,11 +0,0 @@
--- error-chain-0.12.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ error-chain-0.12.1/Cargo.toml 2019-11-20T11:09:51.791818+00:00
@@ -25,7 +25,7 @@
version = "0.3.3"
optional = true
[build-dependencies.version_check]
-version = "0.1.5"
+version = "0.9"
[features]
default = ["backtrace", "example_generated"]

@ -1,27 +1,18 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 13
# * https://github.com/rust-lang-nursery/error-chain/issues/242 %bcond_without check
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
# https://github.com/rust-lang-nursery/error-chain/issues/267
%global __cargo_is_bin() false
%global crate error-chain %global crate error-chain
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.12.1 Version: 0.12.2
Release: 5%{?dist} Release: 1%{?dist}
Summary: Error boilerplate library Summary: Error boilerplate library
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/error-chain URL: https://crates.io/crates/error-chain
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata
# * Update version_check to 0.9, https://github.com/rust-lang-nursery/error-chain/commit/f5417d2eb4f0f1398d61c9ecef948c37a073e563
Patch0: error-chain-fix-metadata.diff
# Finish upgrade of version_check
Patch0001: 0001-Update-version_check-to-0.9.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -47,7 +38,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license LICENSE-MIT LICENSE-APACHE
%doc CHANGELOG.md README.md %doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -59,7 +50,7 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate. which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+backtrace-devel %package -n %{name}+backtrace-devel
Summary: %{summary} Summary: %{summary}
@ -71,7 +62,7 @@ This package contains library source intended for building other packages
which use "backtrace" feature of "%{crate}" crate. which use "backtrace" feature of "%{crate}" crate.
%files -n %{name}+backtrace-devel %files -n %{name}+backtrace-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+example_generated-devel %package -n %{name}+example_generated-devel
Summary: %{summary} Summary: %{summary}
@ -83,10 +74,11 @@ This package contains library source intended for building other packages
which use "example_generated" feature of "%{crate}" crate. which use "example_generated" feature of "%{crate}" crate.
%files -n %{name}+example_generated-devel %files -n %{name}+example_generated-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
find -type f -exec chmod -c -x '{}' '+'
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
@ -104,6 +96,9 @@ which use "example_generated" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Thu Feb 20 2020 Josh Stone <jistone@redhat.com> - 0.12.2-1
- Update to 0.12.2
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.1-5 * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (error-chain-0.12.1.crate) = 1a8baeac9f4d96214a878b5c80ec2c5753c2232a166515c96ad6a42424bbe32410f2acd3aefa70d9dda7036e1965d83aeb9fd1a393b11464fed751aaebc9bbdc SHA512 (error-chain-0.12.2.crate) = 1a64c6813f07d23b091fe3fb69b745711ffcacceffc2ad5e1bf76917ff15d48ba370d63c886441a96a8a88cf645224db46a279152ce6b76878bf8699fbcb43f4

Loading…
Cancel
Save