parent
16aa19eb58
commit
1091812af9
@ -0,0 +1 @@
|
|||||||
|
/errno-0.2.3.crate
|
@ -0,0 +1,13 @@
|
|||||||
|
--- errno-0.2.3/Cargo.toml 2017-02-17T10:48:18+01:00
|
||||||
|
+++ errno-0.2.3/Cargo.toml 2017-11-19T10:20:17.479369+01:00
|
||||||
|
@@ -13,10 +13,6 @@
|
||||||
|
[target.'cfg(unix)'.dependencies]
|
||||||
|
libc = "0.2"
|
||||||
|
|
||||||
|
-[target.'cfg(windows)'.dependencies]
|
||||||
|
-winapi = "0.2"
|
||||||
|
-kernel32-sys = "0.2"
|
||||||
|
-
|
||||||
|
[badges]
|
||||||
|
appveyor = { repository = "lfairy/rust-errno" }
|
||||||
|
travis-ci = { repository = "lfairy/rust-errno" }
|
@ -0,0 +1,61 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate errno
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.2.3
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Cross-platform interface to the `errno` variable
|
||||||
|
|
||||||
|
# https://github.com/lfairy/rust-errno/issues/11
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/errno
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No windows
|
||||||
|
Patch0: errno-0.2.3-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Cross-platform interface to the `errno` variable.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Nov 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.3-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue