commit
48b327dda3
@ -0,0 +1 @@
|
|||||||
|
SOURCES/env_logger-0.9.3.crate
|
@ -0,0 +1 @@
|
|||||||
|
d4e036865058ee95e4bf32b0b58b5ff11fddda0c SOURCES/env_logger-0.9.3.crate
|
@ -0,0 +1,74 @@
|
|||||||
|
From 64b77176e7c9684ef3dcd772bd35615011aedddf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Thu, 8 Aug 2024 17:18:57 +0200
|
||||||
|
Subject: [PATCH] Fix invalid code block attributes in docstrings
|
||||||
|
|
||||||
|
---
|
||||||
|
src/lib.rs | 14 +++++++-------
|
||||||
|
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib.rs b/src/lib.rs
|
||||||
|
index 642b731..a1b49d9 100644
|
||||||
|
--- a/src/lib.rs
|
||||||
|
+++ b/src/lib.rs
|
||||||
|
@@ -32,18 +32,18 @@
|
||||||
|
//!
|
||||||
|
//! Assumes the binary is `main`:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=error ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! ```
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=info ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||||
|
//! ```
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=debug ./main
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
@@ -52,7 +52,7 @@
|
||||||
|
//!
|
||||||
|
//! You can also set the log level on a per module basis:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=main=info ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||||
|
@@ -60,7 +60,7 @@
|
||||||
|
//!
|
||||||
|
//! And enable all logging:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=main ./main
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
@@ -70,7 +70,7 @@
|
||||||
|
//! If the binary name contains hyphens, you will need to replace
|
||||||
|
//! them with underscores:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=my_app ./my-app
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG my_app] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR my_app] this is printed by default
|
||||||
|
@@ -92,7 +92,7 @@
|
||||||
|
//! value of this environment variable is a comma-separated list of *logging
|
||||||
|
//! directives*. A logging directive is of the form:
|
||||||
|
//!
|
||||||
|
-//! ```text
|
||||||
|
+//! ```console
|
||||||
|
//! example::log::target=level
|
||||||
|
//! ```
|
||||||
|
//!
|
||||||
|
--
|
||||||
|
2.46.0
|
||||||
|
|
@ -0,0 +1,150 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.1)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 5;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate env_logger
|
||||||
|
|
||||||
|
Name: rust-env_logger0.9
|
||||||
|
Version: 0.9.3
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Logging implementation configured via an environment variable
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/env_logger
|
||||||
|
Source: %{crates_source}
|
||||||
|
# * backported patch to fix invalid code block attributes in docstrings:
|
||||||
|
# https://github.com/rust-cli/env_logger/commit/b020d97
|
||||||
|
Patch: 0001-Fix-invalid-code-block-attributes-in-docstrings.patch
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A logging implementation for `log` which is configured via an
|
||||||
|
environment variable.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+atty-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+atty-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "atty" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+atty-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+humantime-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+humantime-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "humantime" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+humantime-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+regex-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+regex-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "regex" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+regex-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+termcolor-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+termcolor-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "termcolor" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+termcolor-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.9.3-5
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Thu Aug 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.9.3-5
|
||||||
|
- Backport patch to fix invalid code block attributes in docstrings
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Mar 12 2023 Fabio Valentini <decathorpe@gmail.com> - 0.9.3-1
|
||||||
|
- Initial import (env_logger 0.9 compat package)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue