commit
a3d8a02d0c
@ -0,0 +1 @@
|
|||||||
|
SOURCES/env_logger-0.8.4.crate
|
@ -0,0 +1 @@
|
|||||||
|
0a63ed57ad8f7756e4e220acb7faf2a90c542ebe SOURCES/env_logger-0.8.4.crate
|
@ -0,0 +1,65 @@
|
|||||||
|
From 9a0a0449e55ac9beb274c4a5a6452dcf9eda4c6c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Thu, 8 Aug 2024 17:28:23 +0200
|
||||||
|
Subject: [PATCH] Fix invalid code block attributes in docstrings
|
||||||
|
|
||||||
|
---
|
||||||
|
src/lib.rs | 12 ++++++------
|
||||||
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib.rs b/src/lib.rs
|
||||||
|
index 6a77266..bed2641 100644
|
||||||
|
--- a/src/lib.rs
|
||||||
|
+++ b/src/lib.rs
|
||||||
|
@@ -36,18 +36,18 @@
|
||||||
|
//!
|
||||||
|
//! Assumes the binary is `main`:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=error ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! ```
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=info ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||||
|
//! ```
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=debug ./main
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
@@ -56,7 +56,7 @@
|
||||||
|
//!
|
||||||
|
//! You can also set the log level on a per module basis:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=main=info ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||||
|
@@ -64,7 +64,7 @@
|
||||||
|
//!
|
||||||
|
//! And enable all logging:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=main ./main
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
@@ -74,7 +74,7 @@
|
||||||
|
//! If the binary name contains hyphens, you will need to replace
|
||||||
|
//! them with underscores:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=my_app ./my-app
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG my_app] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR my_app] this is printed by default
|
||||||
|
--
|
||||||
|
2.46.0
|
||||||
|
|
@ -0,0 +1,163 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.1)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 9;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate env_logger
|
||||||
|
|
||||||
|
Name: rust-env_logger0.8
|
||||||
|
Version: 0.8.4
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Logging implementation configured via an environment variable
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/env_logger
|
||||||
|
Source: %{crates_source}
|
||||||
|
# * backported patch to fix invalid code block attributes in docstrings:
|
||||||
|
# https://github.com/rust-cli/env_logger/commit/b020d97
|
||||||
|
Patch: 0001-Fix-invalid-code-block-attributes-in-docstrings.patch
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A logging implementation for `log` which is configured via an
|
||||||
|
environment variable.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+atty-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+atty-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "atty" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+atty-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+humantime-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+humantime-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "humantime" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+humantime-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+regex-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+regex-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "regex" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+regex-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+termcolor-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+termcolor-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "termcolor" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+termcolor-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.8.4-9
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Thu Aug 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.8.4-9
|
||||||
|
- Backport patch to fix invalid code block attributes in docstrings
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.8.4-5
|
||||||
|
- Regenerate with rust2rpm v24
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 11 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.4-1
|
||||||
|
- Initial import (env_logger 0.8 compat package)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue