commit
539d9b9271
@ -0,0 +1 @@
|
||||
SOURCES/env_logger-0.10.2.crate
|
@ -0,0 +1 @@
|
||||
6aef4a1003a7480b482cba552ebcce00c91d6bcb SOURCES/env_logger-0.10.2.crate
|
@ -0,0 +1,79 @@
|
||||
From b020d9754883ce42eab1f38ffc031f0b82b079fe Mon Sep 17 00:00:00 2001
|
||||
From: Ed Page <eopage@gmail.com>
|
||||
Date: Fri, 26 Jul 2024 13:30:09 -0500
|
||||
Subject: [PATCH] docs: Fix infostrings
|
||||
|
||||
---
|
||||
src/lib.rs | 16 ++++++++--------
|
||||
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/lib.rs b/src/lib.rs
|
||||
index f200dc9..b8905e7 100644
|
||||
--- a/src/lib.rs
|
||||
+++ b/src/lib.rs
|
||||
@@ -32,18 +32,18 @@
|
||||
//!
|
||||
//! Assumes the binary is `main`:
|
||||
//!
|
||||
-//! ```{.bash}
|
||||
+//! ```console
|
||||
//! $ RUST_LOG=error ./main
|
||||
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||
//! ```
|
||||
//!
|
||||
-//! ```{.bash}
|
||||
+//! ```console
|
||||
//! $ RUST_LOG=info ./main
|
||||
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||
//! ```
|
||||
//!
|
||||
-//! ```{.bash}
|
||||
+//! ```console
|
||||
//! $ RUST_LOG=debug ./main
|
||||
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||
@@ -52,7 +52,7 @@
|
||||
//!
|
||||
//! You can also set the log level on a per module basis:
|
||||
//!
|
||||
-//! ```{.bash}
|
||||
+//! ```console
|
||||
//! $ RUST_LOG=main=info ./main
|
||||
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||
@@ -60,7 +60,7 @@
|
||||
//!
|
||||
//! And enable all logging:
|
||||
//!
|
||||
-//! ```{.bash}
|
||||
+//! ```console
|
||||
//! $ RUST_LOG=main ./main
|
||||
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||
@@ -70,7 +70,7 @@
|
||||
//! If the binary name contains hyphens, you will need to replace
|
||||
//! them with underscores:
|
||||
//!
|
||||
-//! ```{.bash}
|
||||
+//! ```console
|
||||
//! $ RUST_LOG=my_app ./my-app
|
||||
//! [2017-11-09T02:12:24Z DEBUG my_app] this is a debug message
|
||||
//! [2017-11-09T02:12:24Z ERROR my_app] this is printed by default
|
||||
@@ -88,14 +88,14 @@
|
||||
//! **By default all logging is disabled except for the `error` level**
|
||||
//!
|
||||
//! The **`RUST_LOG`** environment variable controls logging with the syntax:
|
||||
-//! ```text
|
||||
+//! ```console
|
||||
//! RUST_LOG=[target][=][level][,...]
|
||||
//! ```
|
||||
//! Or in other words, its a comma-separated list of directives.
|
||||
//! Directives can filter by **target**, by **level**, or both (using `=`).
|
||||
//!
|
||||
//! For example,
|
||||
-//! ```text
|
||||
+//! ```console
|
||||
//! RUST_LOG=data=debug,hardware=debug
|
||||
//! ```
|
||||
//!
|
@ -0,0 +1,142 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.1)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate env_logger
|
||||
|
||||
Name: rust-env_logger0.10
|
||||
Version: 0.10.2
|
||||
Release: %autorelease
|
||||
Summary: Logging implementation for log which is configured via an environment variable
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/env_logger
|
||||
Source: %{crates_source}
|
||||
# * upstream patch to fix invalid code block attributes in docstrings
|
||||
Patch: https://github.com/rust-cli/env_logger/commit/b020d97.patch
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A logging implementation for `log` which is configured via an
|
||||
environment variable.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+auto-color-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+auto-color-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "auto-color" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+auto-color-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+color-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+color-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "color" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+color-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+humantime-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+humantime-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "humantime" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+humantime-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+regex-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+regex-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "regex" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+regex-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.10.2-3
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Thu Aug 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.2-3
|
||||
- Include upstream patch to fix invalid code block attributes in docstrings
|
||||
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Thu Feb 29 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.2-1
|
||||
- Initial import (env_logger 0.10 compat package)
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue