commit
88e93dceb1
@ -0,0 +1 @@
|
|||||||
|
SOURCES/env_logger-0.11.5.crate
|
@ -0,0 +1 @@
|
|||||||
|
84ced07b29acb093c50e616cc55c767e89f98063 SOURCES/env_logger-0.11.5.crate
|
@ -0,0 +1,79 @@
|
|||||||
|
From b020d9754883ce42eab1f38ffc031f0b82b079fe Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ed Page <eopage@gmail.com>
|
||||||
|
Date: Fri, 26 Jul 2024 13:30:09 -0500
|
||||||
|
Subject: [PATCH] docs: Fix infostrings
|
||||||
|
|
||||||
|
---
|
||||||
|
src/lib.rs | 16 ++++++++--------
|
||||||
|
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib.rs b/src/lib.rs
|
||||||
|
index f200dc9..b8905e7 100644
|
||||||
|
--- a/src/lib.rs
|
||||||
|
+++ b/src/lib.rs
|
||||||
|
@@ -32,18 +32,18 @@
|
||||||
|
//!
|
||||||
|
//! Assumes the binary is `main`:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=error ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! ```
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=info ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||||
|
//! ```
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=debug ./main
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
@@ -52,7 +52,7 @@
|
||||||
|
//!
|
||||||
|
//! You can also set the log level on a per module basis:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=main=info ./main
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
//! [2017-11-09T02:12:24Z INFO main] the answer was: 12
|
||||||
|
@@ -60,7 +60,7 @@
|
||||||
|
//!
|
||||||
|
//! And enable all logging:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=main ./main
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG main] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR main] this is printed by default
|
||||||
|
@@ -70,7 +70,7 @@
|
||||||
|
//! If the binary name contains hyphens, you will need to replace
|
||||||
|
//! them with underscores:
|
||||||
|
//!
|
||||||
|
-//! ```{.bash}
|
||||||
|
+//! ```console
|
||||||
|
//! $ RUST_LOG=my_app ./my-app
|
||||||
|
//! [2017-11-09T02:12:24Z DEBUG my_app] this is a debug message
|
||||||
|
//! [2017-11-09T02:12:24Z ERROR my_app] this is printed by default
|
||||||
|
@@ -88,14 +88,14 @@
|
||||||
|
//! **By default all logging is disabled except for the `error` level**
|
||||||
|
//!
|
||||||
|
//! The **`RUST_LOG`** environment variable controls logging with the syntax:
|
||||||
|
-//! ```text
|
||||||
|
+//! ```console
|
||||||
|
//! RUST_LOG=[target][=][level][,...]
|
||||||
|
//! ```
|
||||||
|
//! Or in other words, its a comma-separated list of directives.
|
||||||
|
//! Directives can filter by **target**, by **level**, or both (using `=`).
|
||||||
|
//!
|
||||||
|
//! For example,
|
||||||
|
-//! ```text
|
||||||
|
+//! ```console
|
||||||
|
//! RUST_LOG=data=debug,hardware=debug
|
||||||
|
//! ```
|
||||||
|
//!
|
@ -0,0 +1,323 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 2;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate env_logger
|
||||||
|
|
||||||
|
Name: rust-env_logger
|
||||||
|
Version: 0.11.5
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Logging implementation for log which is configured via an environment variable
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/env_logger
|
||||||
|
Source: %{crates_source}
|
||||||
|
# * upstream patch to fix invalid code block attributes in docstrings
|
||||||
|
Patch: https://github.com/rust-cli/env_logger/commit/b020d97.patch
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A logging implementation for `log` which is configured via an
|
||||||
|
environment variable.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+auto-color-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+auto-color-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "auto-color" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+auto-color-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+color-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+color-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "color" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+color-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+humantime-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+humantime-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "humantime" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+humantime-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+regex-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+regex-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "regex" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+regex-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+unstable-kv-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+unstable-kv-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "unstable-kv" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+unstable-kv-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.11.5-2
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Thu Aug 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.11.5-2
|
||||||
|
- Include upstream patch to fix invalid code block attributes in docstrings
|
||||||
|
|
||||||
|
* Fri Jul 26 2024 Fabio Valentini <decathorpe@gmail.com> - 0.11.5-1
|
||||||
|
- Update to version 0.11.5; Fixes RHBZ#2299486
|
||||||
|
|
||||||
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 24 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.11.3-1
|
||||||
|
- Update to version 0.11.3 (Fixes RHBZ#2267922)
|
||||||
|
|
||||||
|
* Thu Feb 29 2024 Fabio Valentini <decathorpe@gmail.com> - 0.11.2-1
|
||||||
|
- Update to version 0.11.2; Fixes RHBZ#2258923
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Nov 10 2023 Fabio Valentini <decathorpe@gmail.com> - 0.10.1-1
|
||||||
|
- Update to version 0.10.1; Fixes RHBZ#2249086
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Mar 12 2023 Fabio Valentini <decathorpe@gmail.com> - 0.10.0-1
|
||||||
|
- Update to version 0.10.0; Fixes RHBZ#2148278
|
||||||
|
|
||||||
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Nov 11 2022 Fabio Valentini <decathorpe@gmail.com> - 0.9.3-1
|
||||||
|
- Update to version 0.9.3; Fixes RHBZ#2140630
|
||||||
|
|
||||||
|
* Wed Oct 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.9.1-1
|
||||||
|
- Update to version 0.9.1; Fixes RHBZ#2127651
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 11 2021 Fabio Valentini <decathorpe@gmail.com> - 0.9.0-1
|
||||||
|
- Update to version 0.9.0; Fixes RHBZ#1982310
|
||||||
|
|
||||||
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.4-2
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 18 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.4-1
|
||||||
|
- Update to version 0.8.4.
|
||||||
|
- Fixes RHBZ#1970813
|
||||||
|
|
||||||
|
* Sun Feb 14 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.3-1
|
||||||
|
- Update to version 0.8.3.
|
||||||
|
- Fixes RHBZ#1927897
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 19 2020 Fabio Valentini <decathorpe@gmail.com> - 0.8.2-1
|
||||||
|
- Update to version 0.8.2.
|
||||||
|
- Fixes RHBZ#1899165
|
||||||
|
|
||||||
|
* Mon Nov 09 2020 Fabio Valentini <decathorpe@gmail.com> - 0.8.1-1
|
||||||
|
- Update to version 0.8.1.
|
||||||
|
- Fixes RHBZ#1889010
|
||||||
|
|
||||||
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-4
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Oct 20 2019 Robert Fairley <rfairley@redhat.com> - 0.7.1-1
|
||||||
|
- Update to 0.7.1
|
||||||
|
|
||||||
|
* Sun Aug 18 16:13:12 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.2-1
|
||||||
|
- Update to 0.6.2
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 20 00:12:56 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.1-2
|
||||||
|
- Regenerate
|
||||||
|
|
||||||
|
* Thu Mar 07 2019 Josh Stone <jistone@redhat.com> - 0.6.1-1
|
||||||
|
- Update to 0.6.1
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 14 2019 Josh Stone <jistone@redhat.com> - 0.6.0-1
|
||||||
|
- Update to 0.6.0
|
||||||
|
|
||||||
|
* Tue Oct 30 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.13-2
|
||||||
|
- Adapt to new packaging
|
||||||
|
|
||||||
|
* Thu Aug 30 2018 Josh Stone <jistone@redhat.com> - 0.5.13-1
|
||||||
|
- Update to 0.5.13
|
||||||
|
|
||||||
|
* Sat Aug 04 2018 Josh Stone <jistone@redhat.com> - 0.5.12-1
|
||||||
|
- Update to 0.5.12
|
||||||
|
|
||||||
|
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.11-3
|
||||||
|
- Rebuild to run tests
|
||||||
|
|
||||||
|
* Tue Jul 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.11-2
|
||||||
|
- Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.11-1
|
||||||
|
- Update to 0.5.11
|
||||||
|
|
||||||
|
* Thu Jul 19 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.10-3
|
||||||
|
- Bump termcolor to 1
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.10-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun May 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.10-1
|
||||||
|
- Update to 0.5.10
|
||||||
|
|
||||||
|
* Sun Apr 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.9-1
|
||||||
|
- Update to 0.5.9
|
||||||
|
|
||||||
|
* Wed Apr 18 2018 Josh Stone <jistone@redhat.com> - 0.5.8-1
|
||||||
|
- Update to 0.5.8
|
||||||
|
|
||||||
|
* Fri Apr 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.7-1
|
||||||
|
- Update to 0.5.7
|
||||||
|
|
||||||
|
* Thu Mar 22 2018 Josh Stone <jistone@redhat.com> - 0.5.6-1
|
||||||
|
- Update to 0.5.6
|
||||||
|
|
||||||
|
* Fri Mar 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.5-1
|
||||||
|
- Update to 0.5.5
|
||||||
|
|
||||||
|
* Mon Feb 26 2018 Josh Stone <jistone@redhat.com> - 0.5.4-1
|
||||||
|
- Update to 0.5.4
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.3-1
|
||||||
|
- Update to 0.5.3
|
||||||
|
|
||||||
|
* Fri Jan 19 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.2-1
|
||||||
|
- Update to 0.5.2
|
||||||
|
|
||||||
|
* Thu Jan 18 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
|
||||||
|
- Update to 0.5.1
|
||||||
|
|
||||||
|
* Wed Jan 17 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
|
||||||
|
- Update to 0.5.0
|
||||||
|
|
||||||
|
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.3-2
|
||||||
|
- Rebuild for rust-packaging v5
|
||||||
|
|
||||||
|
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.3-1
|
||||||
|
- Update to 0.4.3
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.2-2
|
||||||
|
- Port to use rust-packaging
|
||||||
|
|
||||||
|
* Wed Mar 08 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.2-1
|
||||||
|
- Update to 0.4.2
|
||||||
|
|
||||||
|
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.1-1
|
||||||
|
- Update to 0.4.1
|
||||||
|
|
||||||
|
* Sat Feb 25 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-1
|
||||||
|
- Initial package
|
||||||
|
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue